Solved

problem with wordpress installation

Posted on 2013-01-28
5
324 Views
Last Modified: 2013-02-03
hi,

i have added a wordpress theme and am getting this error

Fatal error: Call to undefined function wp_get_theme() in /content/Hosting/y/o/y
ourcitybeats.com/web/nuance/wp-content/themes/consultant/admin/index.php

Open in new window

on line 20

attached is the code

<?php
/**
 * Index Template
 *
 * @package WP Consultant
 * @subpackage Template
 */

global $ct_options;

$rev_slider = $ct_options['ct_home_rev_slider_alias'];
$layout_type = $ct_options['ct_layout'];

get_header(); ?>

		<?php
            $layout = $ct_options['ct_homepage_layout']['enabled'];
            
            if ($layout) :
            
            foreach ($layout as $key=>$value) {
            
                switch($key) {
					
				// Slider
				case 'slider' : ?>

                    
                        <?php if(function_exists('putRevSlider')) {
							echo '<div class="slider-wrap">';
                            putRevSlider($rev_slider);
							echo '</div>';
                        } else {
							echo '<div class="activate-slider">';
                            echo '<h3 id="activate-slider">Please upload and activate the Revolution Slider plugin, packed with the main download you got from ThemeForest.</h3>';
							echo '</div>';
                        } ?>
                    </div>
                    
				<?php
                break;
					
				// Featured Listings            
                case 'call_to_action' : ?>
            
                    <div class="cta-wrap">
                        <div class="container">
                            <div class="cta-verbiage">
                                <?php echo $ct_options['ct_cta_text']; ?>
                            </div>
                        </div>
                    </div>
				<?php
                    break;
                        
                    // Featured Listings            
                    case 'portfolio' : ?>
            
                        <div class="portfolio-wrap">
                            <div class="container">
                                
                                <?php if(!is_single()) { ?>
                                <div id="portfolio-inner"></div>
                                <div id="ct-loader"><img src="<?php echo get_template_directory_uri() ?>/images/loader.gif"/></div>
                                <?php } ?>
            
                                <div>
                                    <?php ct_tags_nav(); ?>
                                    
                                    <?php if(!is_single()) { ?>
                                    <a class="view-all right" href="<?php echo home_url(); ?>/?post_type=portfolio"><?php _e('View All', 'contempo'); ?> <em>&rarr;</em></a>
                                        <div class="clear"></div>
                                    <div id="isotope-container">
                                        <?php get_template_part('loop', 'portfolio'); ?>
                                    </div>
                                    <?php } ?>
                                </div>
                            </div>
                        </div>
				<?php
                break;
					
				// Featured Listings            
                case 'page_builder' : ?>
                        
                    <div class="page-builder-wrap">
                        <div class="container">
                            <?php echo do_shortcode('[template id="' . $ct_options['ct_home_page_builder_slug'] . '"]'); ?>
                        </div>
                    </div>
                    
				<?php
				break;
                }
            
            } endif; ?>

<?php get_footer(); ?>

Open in new window

0
Comment
Question by:jonathanduane2010
  • 3
  • 2
5 Comments
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 38828369
When does the error come up?
0
 

Author Comment

by:jonathanduane2010
ID: 38828375
when i try to activate the theme
0
 
LVL 70

Expert Comment

by:Jason C. Levine
ID: 38828399
Something's not right with the packaging, then.  Did you upload the zip file or decompress locally and upload the theme folder via FTP?
0
 

Accepted Solution

by:
jonathanduane2010 earned 0 total points
ID: 38832887
i just applied latest version of wordpress and it sorted it out
0
 

Author Closing Comment

by:jonathanduane2010
ID: 38848314
the latest version of wordpress sorted this problem out
0

Featured Post

DevOps Toolchain Recommendations

Read this Gartner Research Note and discover how your IT organization can automate and optimize DevOps processes using a toolchain architecture.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

An enjoyable and seamless user experience can go a long way on an eCommerce site. While a cohesive layout and engaging copy play roles in creating a positive user experience, some sites neglect aspects that seem marginal but in actuality prove very …
FAQ pages provide a simple way for you to supply and for customers to find answers to the most common questions about your company. Here are six reasons why your company website should have a FAQ page
The viewer will learn how to dynamically set the form action using jQuery.
The viewer will learn how to count occurrences of each item in an array.

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question