Solved

upgraded to Exchange 2007, I can send out email, but couldn't receive  email.

Posted on 2013-01-28
20
301 Views
Last Modified: 2013-02-04
We recently upgraded to Exchange 2007 and we have not remove our Exchange 2003 yet,
 I can send out email to Echange 2003 email box or outside email, but couldn't receive  email the exchange 2003 or outside.
0
Comment
Question by:heq98
  • 9
  • 6
  • 2
  • +3
20 Comments
 
LVL 3

Expert Comment

by:foxpc123
ID: 38828517
What happens if you try a smtp test - try www.mxtoolbox.com put in your domain and then run a SMTP test - can you post the result please.
0
 
LVL 49

Assisted Solution

by:Akhater
Akhater earned 334 total points
ID: 38828521
most of the time it means you have a smart host relay configured on your SMTP virtual server in 2003.

follow this and double check if you have a smart host configured on your 2003

http://technet.microsoft.com/en-us/library/aa996082(v=exchg.65).aspx
0
 
LVL 12

Expert Comment

by:ryan80
ID: 38828608
Are the connectors between the two servers there? There should be two of them.
0
 
LVL 5

Expert Comment

by:Metaltree
ID: 38828785
If both servers are still up, there should be a routing group connector, can you verify this is there?

http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/f379cce6-b440-470e-b262-5a9f0eae53a4
0
 

Author Comment

by:heq98
ID: 38829935
Thank you all for the Answers.

1. foxpc123:my two servers in same doman, not the DNS issue.

2. Akhater:  I have a smart host relay configured on my SMTP virtual server in 2003,
If your Exchange organization contains more than one computer running Exchange, but after I cleaned data in the Smart host box,
i even can't send email outside or the new exchange 2007 millbox(mayemail@yahoo.com)
3.ryan80:from my 2003 exchange system manager, has two connectors, one between the two servers(2003server-2007server), other 2003 server-internet(smart host). on 2007 has same.
4.Metaltree:yes, both servers are still up, has two routing group connector on each server, but my new server is 2007 not 2010.

any other ideal??

Thanks so much!
0
 
LVL 49

Assisted Solution

by:Akhater
Akhater earned 334 total points
ID: 38829938
yes you won't be able to send emails outside, you need to create an SMTP connector instead and configure this one to use the smart-host

please follow this to create and SMTP connector and configure the smart host on the connector level

once you have your external emails working and no smart host on 2003 smtp virutal server let me know

http://support.microsoft.com/kb/265293
0
 

Author Comment

by:heq98
ID: 38829974
My question is how the mail flow going?
A.      Smart host
B.      2003 server
C.      2007 server
D.      Outside server(mail.yahoo.com)
Now:  working Good
      1. B (2003S)->A (Smart Host)->D (Outside server)
      2. D (Outside server)-> A (Smart Host)-> B (2003S)
            3. C (2007S)-> B (2003S) -> A (Smart Host)->D (Outside server)
   Not working
      4. B (2003S) X> C (2007S)
      5. D (Outside server) -> A (Smart Host) -> B (2003S) X> C (2007S)
      
I think the problem between B (2003S) and C (2007S), C to B is working, but B to C is not working.
How can I test it?
0
 
LVL 49

Assisted Solution

by:Akhater
Akhater earned 334 total points
ID: 38829975
i told you the first thing to do is to remove the smart host from the smtp virtual server and move it to the smtp connector.

exchange 2003 will not send emails to 2010 as long as it has a smart host configured on the virtual server level
0
 

Author Comment

by:heq98
ID: 38829978
Akhater: I will try it, thank you very much!
0
 

Assisted Solution

by:heq98
heq98 earned 0 total points
ID: 38830936
Akhater: my current servers confing screen copy attached.
I am going to remove the smart host from the smtp virtual server (2003 smtp virtual server ) and move it to the smtp connector(Internet on 2003).
I will let you know the Result tonight.
exchange-2003-to-2007.jpg
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 49

Expert Comment

by:Akhater
ID: 38830955
Keep me posted
0
 

Assisted Solution

by:heq98
heq98 earned 0 total points
ID: 38833843
Akhater,
I removed the smart host from the smtp virtual server (2003 smtp virtual server ) and move it to the smtp connector(Internet on 2003).

Now, only problem is my exchange 2007 mail box can't receive email from outside(my@yahoo.com), but it can receive email from my 2003 mail box !

 my spam server is pointing to 2003 and 2007 both SMTP server IP (port 25).
0
 
LVL 49

Expert Comment

by:Akhater
ID: 38834270
ok so let me sort this out

1. 2007 -> 2003 working
2. 2003 ->  2007 working
3. internet -> 2003 working
4. internet -> 2007 not working

is that correct ?
0
 
LVL 63

Assisted Solution

by:Simon Butler (Sembee)
Simon Butler (Sembee) earned 166 total points
ID: 38835011
Exchange 2007 by default cannot accept email from an outside source.
You need to enable anonymous on the authentication tab of the DEFAULT receive connector. After doing so, restart the Microsoft Exchange Transport Service.

Simon.
0
 

Author Comment

by:heq98
ID: 38835018
Akhater,
yes, 4. internet -> 2007 not working.
0
 
LVL 49

Assisted Solution

by:Akhater
Akhater earned 334 total points
ID: 38835039
on 2k7 open server config.  Hub transport. Edit the default receive connector last tab make sure anonymous is checked
0
 

Assisted Solution

by:heq98
heq98 earned 0 total points
ID: 38835055
Simon,
you mean on my 2007, Organization configuration--Hub Transport---Accepted Domains

__> my local domain.local ?
0
 
LVL 63

Assisted Solution

by:Simon Butler (Sembee)
Simon Butler (Sembee) earned 166 total points
ID: 38835060
No, that wasn't what I meant.
It is in the Server config, under Hub Transport.
Nothing to do with Accepted Domains.

Simon.
0
 

Accepted Solution

by:
heq98 earned 0 total points
ID: 38835227
on my 2007, Server configuration--Hub Transport---Receive connectors--Default XXXX(Server name)--->properties---Pemission GroupS

V   Anoymous users
V    Exchange users
V    Exhcange servers
V    Legacy Exchange Servers
X    Partners

I restart the Microsoft Exchange Transport Service, it is working.
Thank you all very much for help!!!!!!!!!
0
 

Author Closing Comment

by:heq98
ID: 38850423
those steps very important, shows where is the problem.
0

Featured Post

Too many email signature changes to deal with?

Are you constantly being asked to update your organization's email signatures? Do they take up too much of your time? Wouldn't you love to be able to manage all signatures from one central location, easily design them and deploy them quickly to users. Well, you can!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

930 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now