send and receive email in Exchange Server 2007 very slow (more than 15 minutes)

Hi All,

What should I do when the send and receive email externally took more than 15 minutes to my inbox ?

I have sent test email from Gmail to myself but so far not in my inbox yet ?

What I did recently was to remove the unused old X400 entry as well as the CC: Mail attributes using ADSI edit. as per this article:

Internally its working fine but not externally ?
Senior IT System EngineerIT ProfessionalAsked:
Who is Participating?
suriyaehnopConnect With a Mentor Commented:
1st of all if your mail flow to external is like Exchange > Mail Gateway > Internet


Send Mail:

1. Send to several external account such,gmail, hotmail and etc
2. Verify time when an email reach from Exchange at Mail Gateway and pass to internet
3. Verify the receive date at those external acount

Compare no.2 and no 3.

Receive Mail:

1.  Send an email to internal mail from several external account.
2. Verify time reach at Mail Gateway
3. Verify time reach at Exchange

Compare the time for No.1 and No.2

X400 is for internal mail flow not External
Senior IT System EngineerIT ProfessionalAuthor Commented:
Yes there is a mailhost / smarthost running Solaris as the email gateway.

what could be the possible cause of email delay ?
Senior IT System EngineerIT ProfessionalAuthor Commented:
Thanks !
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.