Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1415
  • Last Modified:

permission denied on /dev/ttyACM0

Permission on /dev/ttyACM0 drive keep on changing back to default which is:

crw-rw---- 1 root uucp 166, 0 Jan 29 13:54 /dev/ttyACM0

I use chmod 777 /dev/ttyACM0, after two minutes it goes back to default permission, I have to use crontab to change the permission regularly.  Is there a way to keep this permission on this device?
0
uknet80
Asked:
uknet80
  • 5
  • 4
4 Solutions
 
Chris SandriniSenior System EngineerCommented:
What distribution are you using? Instead of changing the permission of the file you could add yourself to the group dialout

usermod -a -G dialout username

Open in new window

0
 
uknet80Author Commented:
I am using RHEL 5.6.

Basically, I connected mobile using USB and Gnokii to send SMS to mobiles.
when I am logged into root, I don't have problem, but from browser, I get permission denied.
I need permission on ttyACM0 to be permanent.

can you explain what this command does, you send above.  does it do the job?
0
 
Chris SandriniSenior System EngineerCommented:
Hi

Sorry for RHEL you need to be in UUCP group.

Run this command as root.

usermod -a -G uucp username

Open in new window


Change username to your user.

This command adds your user to the group uucp which is allowed to use ttyACM
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
uknet80Author Commented:
the problem is it apache, I don't know what user it uses?
0
 
Chris SandriniSenior System EngineerCommented:
just look with

ps -ef | grep httpd

and you will see what user it has. If you use standard httpd then the user is apache

usermod -a -G uucp apache

Open in new window

0
 
uknet80Author Commented:
I did add zabbix and apache to uucp group but doesn't work.

I will explain everything here.

as mentioned above the permission is:
crw-rw---- 1 root uucp 4, 64 Jan 29 16:20 /dev/ttyS0

we have a Zabbix server Gnokii to send SMS alert if server is down.

through SSh login I can send SMS alert whether I am logged into root or zabbix users.
But SMS alert doesn't work through the browser.

So if i do Chmod 777 /dev/ttyS0.  it will work through the browser too. but it will change back to default setting after a while.

I don't know what permission to give to /dev/ttyS0 to be able to send SMS through browser.

Windows has Everyone user that can be added to group. but here there isn't everyone to be added to uucp.  what could be the solution?
0
 
Chris SandriniSenior System EngineerCommented:
Hi

You should not change the permission on that file as it will be changed back anyway by the system.

The question is as what user your webserver is running from? What webserver is it? What webapplication is it?
0
 
uknet80Author Commented:
I user crontab to change permission every 1 minutes. I do understand your point.

WebServer is: Apache (redhat, RHEL5.6)
Webserver running on (redhat, RHEL5.6)
webapplication is: Zabbix 2.0 monitoring system

thanks
0
 
uknet80Author Commented:
Group permission solved the issue
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now