Contacts Being Recreated

We are running Exchange 2007 SP3 and most of our users are using Outlook 2007. Some of our users have smartphones, be it iPhones, Android devices, and even Blackberries using our BES server. We began noticing that the Salesforce for Outlook connector was deleting contacts in Salesforce. After much discussion with Salesforce as to why this was happening, we tracked it down to contacts changing in Outlook.

What we noticed in Outlook was that the created date for contacts was changing. All the proper information was there in the contact, it was just like the contact was deleted and recreated. Several people said it must have something to do with the phone sync, however, we've checked people that have no mobile phone sync and it is happening to them as well.

Most of my contacts now have a created date of 10/27/2012. Another on 10/29/2012, and another on 10/30/2012. I even have a few from 1/20/2013 and a couple more from 1/22/2013. I haven't added any contacts in a good 6 months and I know the 2 that show created on 1/22/2013 have been in my contact list for over a year. The 10/27/2012 contacts happen to be the same date we noticed contacts disappearing from Salesforce.

We've exhausted our resources searching for a solution. No one seems to have heard about this before. According to logs, contacts have changed even when Microsoft Outlook 2007 is not even running on a user's account, such as over a weekend. Any insight into this would be very appreciative.
LVL 1
Natas007Asked:
Who is Participating?
 
Natas007Connect With a Mentor Author Commented:
Our issue ended up being with Enterprise Vault. We turned off contact archiving and it fixed our issue.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
This isnt MS related issue for sure ... try to turnoff any other 3rd party softwares you wont see this happen so its Salesforce or some other software for sure

- Rancy
0
 
Natas007Author Commented:
I would like to say that is true, Rancy, but I don't run the Salesforce for Outlook plugin and it is happening to me. Most of our users are running a ViewMail plugin from Cisco for voice mail and the Enterprise Vault plugin for archive access, however I am not running these plugins either. As I also noted in the original question, it is happening when Outlook isn't running on user computers and those users do not have phones that sync to Exchange, so it can't be an Outlook plugin.

Also, I have checked for rules against managed folders in Exchange and we don't have any setup.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Natas007Author Commented:
It appears that it may be our Enterprise Vault server. The nature of our business requires us to keep archives of every email in and out of our system. According to our network change logs, we changed our Enterprise Vault policy in October to archive all mail and contacts that have changed within 0 days each night. A few of my contacts were updated the day they were recreated. Enterprise Vault, by archiving, recreates each item in Exchange when it archives it. I have tested changing a contact and will see if it gets recreated tonight and post an update in the morning.
0
 
Manpreet SIngh KhatraSolutions Architect, Project LeadCommented:
I guess we had some issues sometime back with Enterprise Vault .... its a beautiful product but only some crappy issue and not much help

- Rancy
0
 
Natas007Author Commented:
We found that Enterprise Vault was deleting and recreating anything that it archived.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.