[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Contacts Being Recreated

Posted on 2013-01-29
6
Medium Priority
?
275 Views
Last Modified: 2016-02-17
We are running Exchange 2007 SP3 and most of our users are using Outlook 2007. Some of our users have smartphones, be it iPhones, Android devices, and even Blackberries using our BES server. We began noticing that the Salesforce for Outlook connector was deleting contacts in Salesforce. After much discussion with Salesforce as to why this was happening, we tracked it down to contacts changing in Outlook.

What we noticed in Outlook was that the created date for contacts was changing. All the proper information was there in the contact, it was just like the contact was deleted and recreated. Several people said it must have something to do with the phone sync, however, we've checked people that have no mobile phone sync and it is happening to them as well.

Most of my contacts now have a created date of 10/27/2012. Another on 10/29/2012, and another on 10/30/2012. I even have a few from 1/20/2013 and a couple more from 1/22/2013. I haven't added any contacts in a good 6 months and I know the 2 that show created on 1/22/2013 have been in my contact list for over a year. The 10/27/2012 contacts happen to be the same date we noticed contacts disappearing from Salesforce.

We've exhausted our resources searching for a solution. No one seems to have heard about this before. According to logs, contacts have changed even when Microsoft Outlook 2007 is not even running on a user's account, such as over a weekend. Any insight into this would be very appreciative.
0
Comment
Question by:Natas007
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38831382
This isnt MS related issue for sure ... try to turnoff any other 3rd party softwares you wont see this happen so its Salesforce or some other software for sure

- Rancy
0
 
LVL 1

Author Comment

by:Natas007
ID: 38831453
I would like to say that is true, Rancy, but I don't run the Salesforce for Outlook plugin and it is happening to me. Most of our users are running a ViewMail plugin from Cisco for voice mail and the Enterprise Vault plugin for archive access, however I am not running these plugins either. As I also noted in the original question, it is happening when Outlook isn't running on user computers and those users do not have phones that sync to Exchange, so it can't be an Outlook plugin.

Also, I have checked for rules against managed folders in Exchange and we don't have any setup.
0
 
LVL 1

Author Comment

by:Natas007
ID: 38831694
It appears that it may be our Enterprise Vault server. The nature of our business requires us to keep archives of every email in and out of our system. According to our network change logs, we changed our Enterprise Vault policy in October to archive all mail and contacts that have changed within 0 days each night. A few of my contacts were updated the day they were recreated. Enterprise Vault, by archiving, recreates each item in Exchange when it archives it. I have tested changing a contact and will see if it gets recreated tonight and post an update in the morning.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 52

Expert Comment

by:Manpreet SIngh Khatra
ID: 38832295
I guess we had some issues sometime back with Enterprise Vault .... its a beautiful product but only some crappy issue and not much help

- Rancy
0
 
LVL 1

Accepted Solution

by:
Natas007 earned 0 total points
ID: 38847160
Our issue ended up being with Enterprise Vault. We turned off contact archiving and it fixed our issue.
0
 
LVL 1

Author Closing Comment

by:Natas007
ID: 38863275
We found that Enterprise Vault was deleting and recreating anything that it archived.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Are you an Exchange administrator employed with an organization? And, have you encountered a corrupt Exchange database due to which you are not able to open its EDB file. This article will explain all the steps to repair corrupt Exchange database.
As much as Microsoft wants to kill off PST file support, just as they tried to do with public folders, there are still times when it is useful or downright necessary to export Exchange mailboxes to PST files. Thankfully, it is still possible to e…
This tutorial gives a high-level tour of the interface of Marketo (a marketing automation tool to help businesses track and engage prospective customers and drive them to purchase). You will see the main areas including Marketing Activities, Design …
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question