Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2013 - reset virtual directories - ecp login failure

Posted on 2013-01-29
7
Medium Priority
?
15,570 Views
Last Modified: 2017-04-05
For some reason I've changed authentication settings for some virtual directories directly in IIS (enabling / disabling "Basic Authentication", "Windows Authentication"...) I know, I've made mistake!
Now I'm unable to login to https://exchangeurl/ecp. Although I'm certain that I've entered accurate username/password, I'm constantly getting the same login page with message that entered credentials are not ok.
I suppose that it can be solved if I can reset all virtual directories in their original state. So my question is:
How can I reset virtual directories?
Is there any documentation on how to setup virtual directory authentication for all virtual directories?
Or one can suggest the other way for me to successfully login to url/ecp, and reset virtual directories from there.
Of course, keep in mind that I'm unable to login to url/ecp, so I must find a way to resolve this using other tools (powershell...)
Thanks!
0
Comment
Question by:fd4u
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 8

Expert Comment

by:vSolutionsIT
ID: 38831197
0
 
LVL 8

Accepted Solution

by:
vSolutionsIT earned 2000 total points
ID: 38831215
You can check the authentication settings by using get-ecpvirtualdirectory | fl command and then may change the authentication settings by using set-ecpvirtualdirectory command.

get-ecpvirtualdirectory :
http://technet.microsoft.com/en-us/library/dd351058.aspx

set-ecpvirtualdirectory
http://technet.microsoft.com/en-us/library/dd297991.aspx

you can remove and then recreate ecp virtual directory using below commands as well. but before that note down all the settings reported by get-ecpvirtualdirectory.

Remove-EcpVirtualDirectory
http://technet.microsoft.com/en-us/library/dd351147.aspx

New-ecpvirtualdirectory:
http://technet.microsoft.com/en-us/library/dd351218.aspx
1
 

Author Comment

by:fd4u
ID: 38831314
Thanks for the answers guys. I'll accept those, but just one more thing: if I delete / recreate ecp directory will I loose some other settings (mailboxes, etc.)?
Thanks
1
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Closing Comment

by:fd4u
ID: 38831386
It was solution I've searched for. Thanks
0
 

Expert Comment

by:nitinawate
ID: 39240879
For similar issue it didn't help for me
0
 

Expert Comment

by:nitinawate
ID: 39240888
Initially I was facing issue earlier only with OWA on E2013(Single box), was failing with below error,
Something went wrong
A mailbox couldn't be found for NT AUTHORITY\SYSTEM. If the problem continuous contact your helpdesk.

So we reset OWA virtual directory using ECP console but didn't help so rebooted E2013 server and found both OWA & ECP stopped working.

But now if we try to browse OWA or ECP console, we get credential page and after putting credential, I get below error,
The user name or password you entered isn't correct. Try entering it again.

I can browse other virtual directories using same credential but not OWA/ECP

Outlook works fine.

Created new mailbox but same issue
0
 
LVL 16

Expert Comment

by:Jason Crawford
ID: 42079963
You can recreate the vDirs, but I would think performing a point in time restore before installing the CU would be a better option.  With that said I'm sure you wouldn't be on this website if you had a backup.

https://technet.microsoft.com/en-us/library/ff629372(v=exchg.141).aspx
1

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
There are times when we need to generate a report on the inbox rules, where users have set up forwarding externally in their mailbox. In this article, I will be sharing a script I wrote to generate the report in CSV format.
In this video we show how to create a Contact in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Contact ta…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question