Solved

DAG Error "No static address matched networks"

Posted on 2013-01-29
8
3,585 Views
Last Modified: 2013-02-03
Hello All-
I’ve got a 3-node Exchange 2010 SP2 DAG in place. Two primary nodes are at one location and the third (different location,AD Site and subnet) contains copies of the databases. All locations are well-connected.

When I tried to enable DataCenterActivationMode, I received the following error: [PS] C:\Windows\system32>Set-DatabaseAvailabilityGroup -Identity "dag1" -DatacenterActivationMode DagOnly
WARNING: No static address matched networks 'Cluster Network 2'. Specified static addresses: '151.x.y.23'
WARNING: Network name ‘dag1' is not online. Please check that the IP address configuration for the database availability group is correct.

Now, I can mount and dismount mailbox databases, activate the copies – all without error. The IP address in the error is the IP address assigned via the EMC GUI when I first stood up the DAG. Also, the Cluster Administrator shows the cluster as being online.

Once everything was stood up last night, no additional error messages were generated by the Cluster Service so everything <appears> to be working properly.

Reviewing the DAGTASK logs, below is the only error that was generated. I was adding a 3rd member to the DAG. Originally, before the 2nd site was stood up, I had a 2-Node DAG with File Share Witness. Here is the error:
[2013-01-28T18:56:44] Updated Progress 'Checking if Mailbox server 'WUDCUSTEX' is in a database availability group.' 14%.
[2013-01-28T18:56:44] Working
[2013-01-28T18:56:44] GetRemoteCluster() for the mailbox server failed with exception = An Active Manager operation failed. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"OpenCluster(WUDCUSTEX.WXD.COM) failed with 0x6d9. Error: There are no more endpoints available from the endpoint mapper"' failed... This is OK.
[2013-01-28T18:56:44] Ignoring previous error, as it is acceptable if the cluster does not exist yet.
[2013-01-28T18:56:44] DumpClusterTopology: Opening remote cluster dag1.
[2013-01-28T18:56:44] Dumping the cluster by connecting to: dag1.

According to the log, the DAG is now ignoring the FSW even though it does not like me removing it from the DAG definition.

Final bits of information:
All 3 DAG nodes have a SINGLE network card for both MAPI and replication traffic. I know this is not optimal or best practice but geo-political forces beyond my control forced me to this configuration. A second NIC is not an option.

Exchange Trusted Subsystem is a member of each Exch2010 server's local admin group

I’ve seen some posts of a similar nature to what I’m experiencing but nothing that fits my environment so any and all help is appreciated.
Regards,
Eric
0
Comment
Question by:Cymbaline65
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
8 Comments
 
LVL 43

Expert Comment

by:Amit
ID: 38832385
What OS level AV you are using. Just stop it and try again. I assume firewall settings are configured properly and there are no time sync issue. Also, want to know, if these are VM or Physical Servers.
0
 

Author Comment

by:Cymbaline65
ID: 38832410
Hello Amitkulshrestha-
OS: Windows 2008 R2
Firewall: Firewall disabled but service is running
Machines: Machines are virtualized on VMWare host platform
Time: Time is synched
Eric
0
 
LVL 43

Expert Comment

by:Amit
ID: 38832422
What about Remote Registry Service? Is that running on 3 server.
0
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

 

Author Comment

by:Cymbaline65
ID: 38832431
Remote Registry Service on on all DAG members
0
 
LVL 43

Expert Comment

by:Amit
ID: 38832448
ya, that should be running and set to automatic
0
 

Author Comment

by:Cymbaline65
ID: 38832459
It is. Researching where it may be related to multiple AD sites and subnets.
0
 
LVL 43

Accepted Solution

by:
Amit earned 500 total points
ID: 38832491
0
 

Author Closing Comment

by:Cymbaline65
ID: 38848943
Sorry to take so long to update. Indeed it was adding the additional DAG IP from the second site to the DAG configuration.
Not enough time to prep and research prior to actually doing the work.
Thanks!
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
how to add IIS SMTP to handle application/Scanner relays into office 365.
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Suggested Courses

615 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question