What does it mean when styling is crossed out?

I've set text-decoration for links to none.  But I still see an underline.  Looking in Firebug, there is a second instance that overrides the first.  Is this why the underline is still there?  

firebugWhat does it mean when there is a second instance crossing out the first one?
brettrAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
deviprasadgConnect With a Mentor Commented:
CSS properties are also crossed out if they are overwritten by another rule. This helps you determine specificity problems, as well as seeing why certain styles are not applying the way you had hoped.

Please refer: http://stackoverflow.com/questions/2412561/in-firebug-how-to-tell-what-is-overriding-a-style

http://blog.themeforest.net/tutorials/firebug-a-developers-best-friend/
0
 
brettrAuthor Commented:
I can disable the second instance but don't see any change.  The underline is still there on links.  What does this mean?

firebug
0
 
Dave BaldwinFixer of ProblemsCommented:
That probably means you haven't turned it off.  Underlining links is the default in most browsers.  See here: http://www.w3schools.com/css/css_pseudo_classes.asp
A common way of killing the underline is using ...
a:link {text-decoration:none;}

Open in new window

0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
brettrAuthor Commented:
Yes - I have that but it has no effect.
0
 
Dave BaldwinFixer of ProblemsCommented:
Then you have it somewhere else also that is overwriting that one.  Add...
a {text-decoration:none;}
a:link {text-decoration:none;}
a:hover {text-decoration:none;}

Open in new window

0
 
brettrAuthor Commented:
I have all the above already.  How do I track down the override?

From the 2nd screenshot, you can see I have disabled the overrides.  The first instance of #footer a is all that is left at that point.
0
 
HagayMandelConnect With a Mentor Commented:
These links are not affected by your CSS, and that means that either they are not positioned within an element with an id of "footer", or somewhere in your CSS file, on a higher level element, there's a CSS rule that contains the '!important' instruction.
The best you can do, is provide a link or a complete code (HTML & CSS)
0
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
Clearly you don't have all that and the code you posted ONLY affects the #footer and does not cover 'text-decoration' which is needed for 'underline'.  'border' is not 'underline'.
0
 
Kim WalkerConnect With a Mentor Web Programmer/TechnicianCommented:
What we can't see in the screen capture you've posted is the location of the styles that are taking precedence. To the far right of these styles is the name of the css file and the line within that file where these styles are located. This is cut off of the screen capture above. If these two styles are not in the same css file, either you have another css file being loaded afterward or you have a style definition embedded within your html. In either case, neither of these styles controls the underline outside of Firefox. Both of them deactivate a Firefox specific underline.

The topmost style in the Firebug list is the style with precedence. It can override any of the styles listed beneath it. So disabling the second instance does nothing when the same styles are included in the top instance. In this case, those styles in the second instance are already deactivated (overridden) by the top instance.

Even though the underline should be deactivated in Firefox, the link element (a tag) is being adorned with a bottom border in the second instance. The border style is not included in the top instance so it remains active. This bottom border would look very much like an underline. If the underline were also present, it would appear as a double underline since the border should appear lower than the underline.

Try disabling in Firebug the bottom border styles in the second instance. What looks like an underline should disappear. If it doesn't, look below these two instances for the "text-decoration" attributes (NOT "-moz-text-decoration"). If there are no instances of text-decoration, the default underline for a tags is still active. Most likely, though, you are seeing the bottom border instead of an underline.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.