[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2025
  • Last Modified:

Installing WordPress on Windows Server 2008 R2 using WPI, cannot access database using "root" login for configuration

Hello,

I am just starting to have a look at using WordPress and seem to have fallen at the first hurdle.

I have installed PHP using the WPI and that seems to be working fine as everything is running as it should. I have previously installed MySQL as well, though that was from the MySql website.

When installing WordPress it all seems to work ok until it wants to configure the database when it then fails. I get a message saying that it wants to connect to the localhost database using the root login and have to type in my password for the root. I do so and then get a message saying that the password is incorrect or it can not connect to the database server.

I have done a search online and found people with a similar problem though no real answers on how to fix it.

The database is running and working correctly and I know I have the password correct as I have created a PHP test script which is connecting fine.

Am I missing something, is there something else I need to do? Can I setup WordPress without having to install through WPI?

Thanks,

Lee
0
Lee Redhead
Asked:
Lee Redhead
  • 3
1 Solution
 
Aaron TomoskyTechnology ConsultantCommented:
There is a wpi for Wordpress that does php, MySQL and Wordpress. I'd suggest removing your current versions and running that.
0
 
David Johnson, CD, MVPOwnerCommented:
That or just go to wordpress.com and download wordpress and go through the install process
0
 
Aaron TomoskyTechnology ConsultantCommented:
The default MySQL install only let's root connect from localhost. If you are on localhost but trying to use a real DNs as your connection string, that will fail also.
Another large problem setting all this up is user rights. Make a phptemp folder in c:\inetpub, and point all the temp stuff in php.ini to use that. Then take that folder as well as your wwwwroot folder (which should be where your site is) and add iusrs group (or is it iis_usrs? i cant recall atm) and the iusr user read and write permissions recursively.
0
 
Lee RedheadAuthor Commented:
I followed the instructions in the end and installed manually, without any problems at all.

It looks like there is something with the WPI and MySQL as Drupal and Joomla had the same issue when installing. I even edited the permissions of MySQL temporally to allow all connections to root to test but no avail.
0
 
Aaron TomoskyTechnology ConsultantCommented:
Agreed. I just needed this again and used ms web installer 4 for Wordpress. Has to delete and reinstall MySQL because it was acting wired with logins.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now