crystal reports parameter is showing all records

Have a report where I have 3 different parameter fields.
1. Year
2. Period
3. Code

When I run these I get all data from that table. Even when I just use one parameter i still have the same issue.
How I set it up:
Parameter: New
Type Name
Value Filed: I select in the drop down Year
I hit ok.
Then I drag that field to my report.
Save
Run  report and it ask for year, I put in the year and I get every year.
scottwoltjerAsked:
Who is Participating?
 
Ross TurnerConnect With a Mentor Management Information Support AnalystCommented:
You need to add your paremeter to selection expert :

1 create new paremeter
2 name your paremeter eg Year
3 select data type e.g number
4 select dynamic or static e.g dynamic
5 select the field you want to map to e.g year
Save

Now with your year paremeter open your selection expert and add

{YourDatabase.Year} = @year


Now you have added your param go back to the field explorer and drag on {YourDatabase.Year}



You can read about it here
http://msdn.microsoft.com/en-us/library/ms227825(v=vs.80).aspx

Or watch a video for the same principle but with dates
Crystal Params Selection
0
 
scottwoltjerAuthor Commented:
Where I add in the paremeter is where I am getting lost.
0
 
scottwoltjerAuthor Commented:
I was clicking on the wrong selection expret. I was in the selection expert of the detail selection.
This is working. Sorry to take so long.

Thanks
0
All Courses

From novice to tech pro — start learning today.