• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 175
  • Last Modified:

unable to copy a file to created folder

hi guys

I created a new directory using 'mkdir customerautomation' in myunix box
but when i trying to copy a file into that diretory (using filezilla)  i am getting
permission denied, any idea how i can change that?

$ ls -ltr
drwxr-xr-x  2 customerproj customerproj  96 Jan 30 18:11 customerautomation


thanks
0
royjayd
Asked:
royjayd
  • 3
  • 3
1 Solution
 
royjaydAuthor Commented:
hi..any inputs will be greatly appreciated.
How do i make sure i give all the permissions to
customerautomation directory so that i can copy files in it?

thanks in advance.
0
 
woolmilkporcCommented:
The userid specified in Filezilla must be "customerproj". To allow writing to that directory by the members of group "customerproj" add group-write permission with "chmod g+w customerautomation".

You could make the directory world-writeable (this is strongly discouraged for security reasons!) with "chmod a+w customerautomation".
0
 
royjaydAuthor Commented:
hi

tried chmod g+w customerautomation",  it doesnt work
tried  chmod a+w customerautomation , it works

>>>this is strongly discouraged for security reasons

can you tell me what security problems may arise? and any reason why
g+w customerautomation doesnt work

thanks
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
woolmilkporcCommented:
g+w doesn't work because the user specified in Filezilla is not a member of the "customerproj" group.

A world-writeable directory is considered a security risk because everybody who has access to the server can add or delete files there.
0
 
royjaydAuthor Commented:
ok thanks
I have read what you said earlier carefully.

<<<
The userid specified in Filezilla must be "customerproj". To allow writing to that directory by the members of group "customerproj" add group-write permission with "chmod g+w customerautomation". >>>

Actually the user specified in filezilla is my company userId.
How do i check and possibly add/enable my userId so that i can write to customerproj

thanks
0
 
woolmilkporcCommented:
id myuserID

will show you the user's primary group ("gid=...") and the other groups ("groups=...") where the user is a member of (if any).

Which command to use for adding myuserID to a certain group is OS dependent.

Which is your OS?

Under SuSE Linux you would use:

groupmod -A myuserID customerproj

Under other Linuxes it should be

usermod -a -G customerproj myuserID

AIX:

chgrpmem -m + myuserID customerproj
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now