• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 526
  • Last Modified:

Programatically disable reply to all?

Greeting experts,

I am on Domino 8.5.2 on Windows 2003 Enterprise. Is there a field I can add to a form that is then sent as email to prevent people from copying, forwarding or replying to all when that document is received?

For some odd reason people are not really reading their email and are basically "spamming" others. The database owner would like to prevent that and I as the database developer would like to oblige as much as I can.

However if this cannot be done, I will just explain it to them.

Thank you.

Awaiting your answers,

Notes Rookie
0
notesrookie
Asked:
notesrookie
  • 3
  • 3
  • 3
1 Solution
 
larsberntropCommented:
You can turn on "Prevent copying" in Delivery options, but that is an all or nothing solution.  There is no option to turn it on just for Reply all. Any copying, printing or forwarding is "discouraged" as the Notes Help puts it.  The mechanism uses the field $KeepPrivate = "1", works in other forms as well.

Another solution is to make a separate copy of the Memo form, which is sent with a Stored Form, which has no Reply All.  But then the view still has Reply all.
0
 
larsberntropCommented:
You could create a new version of the mail template with changed Reply All buttons.

If you do this, do not edit the original template but create a copy.  And try to implement Source code control.
0
 
Sjef BosmanGroupware ConsultantCommented:
If the form is sent with the mail, you can do something:
  1.      Open the form.
  2.      Choose Design - Form Properties.
  3.      Click the Security tab.
  4.      Click "Disable printing/forwarding/copying to clipboard."
Straight from the document "Access-controlled forms and documents" in the Designer Help database... So it only works when you use (the equivalent of) doc.Send(True)
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
larsberntropCommented:
sjef's solution turns it on for all documents based on that form.  It sets the same flag: the item $KeepPrivate"is set to "1"
0
 
Sjef BosmanGroupware ConsultantCommented:
Ah, yes, $KeepPrivate... I forgot its name. Thanks!

Just a remark: $KeepPrivate is a Notes-only thing, whose powers are lost when the mail is sent to a non-Notes user.
0
 
notesrookieAuthor Commented:
Thank you, all. I will check that out.

Regards - Notes Rookie
0
 
notesrookieAuthor Commented:
Apologies, all. It has been a crazy 2 months.
0
 
Sjef BosmanGroupware ConsultantCommented:
Any reason to assume that the next 2 months won't be even crazier? ;-)
0
 
notesrookieAuthor Commented:
thank you!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

  • 3
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now