AIX ulimit

Hi wmp,

I'm having a issue writing a file (db export) that seems to be larger than 2Gb.

A file cannot be larger than the value set by ulimit.

 ulimit -a
time(seconds)        unlimited
file(blocks)         unlimited
data(kbytes)         unlimited
stack(kbytes)        4194304
memory(kbytes)       65536
coredump(blocks)     0
nofiles(descriptors) unlimited

However, file limit doesn't seem to exist.

Any idea how to solve this one?
It's AIX 5L 5.3.

Thanks!
LVL 1
g0allAsked:
Who is Participating?
 
woolmilkporcConnect With a Mentor Commented:
OK, JFS without large files support (bf:false) has a 2 GB file size limit.

Large files support is configured (or not!) at FS creation time and cannot be added afterwards.

Sad to say - either use a different FS (JFS2 or bf:true) as the target for the DB exports or delete the FS and recreate it as JFS2 or at least with bf:true.

Or convice the DB export utility to create chunks of output data not larger than 2 GB.

ORACLE exp and expdp have a parameter "FILESIZE", for example.
0
 
woolmilkporcCommented:
Well,

the ulimit seems indeed OK.

Does the target directory reside on a JFS (not JFS2) filesystem?

With JFS there is a file size limit of 2 GB, unless the FS was created using the largefiles option ("bf=true").
Check with  "lsfs -q /mount/point" and search for the "VFS" type and for "bf:"

Could it be that quota checking is enabled on the target filesystem?

Check with "quota" and "quota -g".
0
 
g0allAuthor Commented:
Currently checking.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
woolmilkporcCommented:
Listening ...
0
 
g0allAuthor Commented:
/data/ora/bla/bla2:
        dev             = /dev/lv_bla
        vfs             = jfs
        log             = /dev/lj_vg_bla
        mount           = true
        check           = false
        options         = rw,nodev
        account         = false


Seems to be JFS1...
0
 
woolmilkporcCommented:
lsfs -q /data/ora/bla/bla2

?
0
 
g0allAuthor Commented:
Half an hour please driving
0
 
woolmilkporcCommented:
Bon voyage!
0
 
g0allAuthor Commented:
Thanks.

smitty drive.
0
 
g0allAuthor Commented:
Name            Nodename   Mount Pt               VFS   Size    Options    Auto Accounting
/dev/lv_bla --        /data/ora/bla/bla2   jfs   25690112 rw,nodev   yes  no
  (lv size: 25690112, fs size: 25690112, frag size: 4096, nbpi: 4096, compress: no, bf: false, ag: 8)
0
 
g0allAuthor Commented:
Thanks, wmp.
0
 
g0allAuthor Commented:
wmp, are you into Oracle also?

export chunks was the accepted solution. I wasn't aware of such option.
0
 
woolmilkporcCommented:
Well, I know a bit about Oracle, but I'm sure there's quite a lot of fine Oracle experts around here at EE to assist you much better than I could.
OK, might be worth a try ...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.