[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Windows Small Business Server 2011 Standard & Exhcange 2010 - Connecting Phones

Posted on 2013-01-31
15
Medium Priority
?
669 Views
Last Modified: 2013-01-31
Manually specify server settings at https://www.testexchangeconnectivity.com - see Image1.jpg for setup and test1.txt for result. (It works just fine)

Using Autodiscover specifying server settings at https://www.testexchangeconnectivity.com - see Image2.jpg for setup and test2.txt for result. (this does not work at all)

The GoDaddy certificate is issued to remote.mydomain.com.

I've tried this: http://www.thirdtier.net/2009/02/setting-up-an-external-autodiscover-record-for-sbs-2008/

But it did not help.

The main problem is that I seem to be unable to connect with any phones to the Exchange no matter how I try to enter the username/domain/server.

Using: remote.mydomain.com in a browser and I get to the usual rwa portal.

Note: Local PC's using Outlook works just fine and have been for a few weeks.
Note: The use of "remote.mydomain.com" is not the actual domain just dont want to post it here.
Note: I've tried a Samsung Note and Samsung Sensation

Any ideas on how to proceed to get phones to sync with the Exchange?
Image1.jpg
Image2.jpg
test1.txt
test2.txt
0
Comment
Question by:tsnirone
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
15 Comments
 
LVL 59

Expert Comment

by:Cliff Galiher
ID: 38839688
Near the end of your test results in trst2

"The autodiscover SRV record wasn't found in DNS."

Tis means you didn't properly follow the a third Tier article you linked to. If you create the SRV record properly, that test result will change. Because we don't have the real domain name, we can't give you more detailed advice than that.
0
 
LVL 3

Author Comment

by:tsnirone
ID: 38839822
Thank you cgaliher!

Please have a look at the attached "Image3.jpg" - I've tried both remote.mydomain.com and mail.mydomain.com as data for the record but none seemed to work.

Will it take some time before it starts working?
Image3.jpg
0
 
LVL 59

Expert Comment

by:Cliff Galiher
ID: 38839843
That is your internal DNS server. You need to create the record with your DNS host, wherever your EXTERNAL records exist.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 3

Author Comment

by:tsnirone
ID: 38839854
I know its the internal dns...that is what is dicussed in the link

http://www.thirdtier.net/2009/02/setting-up-an-external-autodiscover-record-for-sbs-2008/

??

Edit: Sorry for being slow - this is all new to me...

So..I should (at my domain host) add a SRV record pointing to remote.mydomain.com (port 443) then?  Like:

Hostname - TTL - RRtype - Pri - Weight - Port - Data
autodiscover.mydomain.com - 1 - SRV - 100 - 1 - 443 - remote.mydomain.com

?

Should I delete the internal dns one or...?
0
 
LVL 59

Expert Comment

by:Cliff Galiher
ID: 38840022
Yes, delete the internal one. And no, that is not what is discussed in that link. Both the URL itself and the contents refers to external records.

As far as the record itself, each DNS host has a slightly different way if handling SRV records. But you'll need to get it to ,arch what is listed in the article, namely don't forget the protocol, which is tcp, and don't forget the underscores.
0
 
LVL 3

Author Comment

by:tsnirone
ID: 38840169
Ok, thank you again!! I added this:

Hostname - TTL - RRtype - Pri - Weight - Port - Data
_autodiscover._tcp.mydomain.com - 1 - SRV - 100 - 1 - 443 - remote.mydomain.com

and redid the test - see "test3.txt" - seems good!!! :) So progress! Thanks!

But I still get this message on the Samsung Note:

! Setup could not finish
Failed to search Exchange server automatically. Enter settings manually

Hmm...could it be a Exchange-related problem on the user-level....?

The user I use on the www.testexchangeconnectivity.com is different than the one I've used on the Note....

Edit:
On the Samsung Note I've been using "username@mydomain.com"
On the www.testexchangeconnectivity.com I've been using "test@mydomain.com"

Unfortunately - none of them work when trying to autodiscover on the Samsung note.
test3.txt
0
 
LVL 59

Expert Comment

by:Cliff Galiher
ID: 38840259
So try using your test account with the Phone. If it works, you know it is user specific.
0
 
LVL 3

Author Comment

by:tsnirone
ID: 38840327
Yes, sorry...I edited the above post.

The user I use on the www.testexchangeconnectivity.com is different than the one I've used on the Note....

Edit:
On the Samsung Note I've been using "username@mydomain.com"
On the www.testexchangeconnectivity.com I've been using "test@mydomain.com"

Unfortunately - none of them work when trying to autodiscover on the Samsung note.
0
 
LVL 59

Expert Comment

by:Cliff Galiher
ID: 38840364
Sometimes autodiscover can't map the email address to the mailbox name. I see this often with android. When it errors it should provide a place to add the info manually.

Use the account login, the domain, and the password. See if that works.
0
 
LVL 3

Author Comment

by:tsnirone
ID: 38840366
Here's the zonefile:

Zonefile for mydomain.com

; (1 server found)
;; global options: +cmd
mydomain.com.                    3600 IN SOA dns1.host.com. hostmaster.myhost.com. xxxxxxxxxx xxxx xxx xxxxxxx xxxx
mydomain.com.                    3600 IN NS  dns1.host.com.
mydomain.com.                    3600 IN NS  dns2.host.com.
mydomain.com.                    3600 IN NS  dns3.host.com.
mydomain.com.                    3600 IN MX  10 remote.mydomain.com.
_autodiscover._tcp.mydomain.com. 3600 IN SRV 100 1 443 remote.mydomain.com.
remote.mydomain.com.             3600 IN A xxx.xxx.xxx.xxx
www.mydomain.com.                3600 IN A xxx.xxx.xxx.xxx
mydomain.com.                    3600 IN SOA dns1.host.com. hostmaster.myhost.com. xxxxxxxxxx xxxx xxx xxxxxxx xxxx
;; Query time: 0 msec
;; SERVER: xxx.xxx.xxx.xxx#xxx(xxx.xxx.xxx.xxx)
;; WHEN: Thu Jan 31 17:24:45 2013
;; XFR size: 10 records (messages 1, bytes 345)

Open in new window

0
 
LVL 3

Author Comment

by:tsnirone
ID: 38840531
Yeah, the manual approach works...I would like for autodiscover to work though....
0
 
LVL 59

Accepted Solution

by:
Cliff Galiher earned 2000 total points
ID: 38840547
That isn't an issue with your setup, as your final test showed. All passed. Some mobile platforms are just not properly implementing EAS so it doesn't work as expected. That is an issue for the mobile device maker, not exchange or Sbs, unfortunately,
0
 
LVL 3

Author Comment

by:tsnirone
ID: 38840600
Ok. I understand. Thanks cgaliher!

One last thing:

What is the "defacto standard" (if there ever was such a thing) for typing in the username and domain when the mobile device gives you these alternatives:

1.
"Domain"
"User"

2.
"Domain\User"

is it:

1.
"internaldomain" (this would be the internal domain for the dc typically the whole would be "internaldomain.local")
"username" (without the @mydomain.com")

2.
"internaldomain\username" or "internaldomain.local\username" or ?
0
 
LVL 59

Expert Comment

by:Cliff Galiher
ID: 38842210
Well, you have to understand that the short version if mydomain and long version mydomain.local can, in fact, be very different. One is often called an FQDN, and the shorthand is the netbios-compatible version, and is not required to be the same.

For example, my FQDN could be MyLongCompanyName.local and the netbios network name may be MLCN.

If the phone offers a separate domain box and username box, use the FQDN in the domain box and justnthenusername in the username box.

If no domain box is present, use netbios\username

I've found that to be pretty consistently true.
0
 
LVL 3

Author Closing Comment

by:tsnirone
ID: 38842513
Thank you cgaliher. :)
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
I don't pretend to be an expert at this, but I have found a few things that are useful. I hope that sharing them here will help others, so they will not have to face some rather hard choices. Since I felt this to be a topic of enough importance and…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question