• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1621
  • Last Modified:

Outlook attempting to connect to in-house Exchange instead of Office365

Our client uses Office 365 for hosted Exchange.  They have a Small Business Server 2008 server as well onsite.  Up until recently Outlook would properly connect to Office 365, however this week some users are getting security pop-ups when opening outlook.  It appears as if it is trying to connect to the local exchange server instead of the hosted.  

I believe their were registry fixes that can be done on the local PC so it doesn't look for the local exchange server.  Can anyone help?  I am hesitant to make server/powershell changes unless that is the only way to resolve.
0
tampatechman
Asked:
tampatechman
  • 2
  • 2
1 Solution
 
Cliff GaliherCommented:
Outlook 2007 and later will use autodiscover to reconfigure outlook, and this relies on settings in AD, so no client-side fix works. You must disable autodiscover on the server side.

With that said, if you aren't using exchange, I would not recommend staying on SBS. It isn't designed to be ep decoupled like that and the CALs are more expensive. As SBS 2008 will be moving into extended support only, now is a great time to look at moving to a newer platform. That will solve your problem nicely and prevent other issues that arise from running SBS without exchange.
0
 
tampatechmanAuthor Commented:
cgaliher - what is the process to disable autodiscover on the local server side?
0
 
Cliff GaliherCommented:
The easiest is to just pull the vdir. This is a destructive process, so HAVE A TRUSTED BACKUP.

The powershell command is remove-autodiscovervirtualdirectory
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now