Citrix Policy "CPU Management Server Level" and Dynamic Fare Share Scheduling (DFSS)

Hi,
While looking into problems with processes going high on CPU/memory, in our Xenapp 6.5/Win 2008 R2-servers I came across the Citrix Policy "CPU Management Server Level", which we have enabled with value "Fair sharing of CPU between sessions". A note in this policy reads: Note: To use CPU Utilization Management, ensure that the Dynamic Fair Share Scheduling (DFSS) feature of Windows is disabled on the server.
I tried to look up:
- if we have DFSS enabled on our servers
- and, if so, how we can turn of DFSS

But I am a bit confused of my findings:
- In this link, http://windoh.wordpress.com/2012/04/17/dfss-doesnt-work-as-expected/ 
I found that we should have a value in the registry that tell us if DFSS is enabled or not
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\SessionManager\DFSS
, but I can´t find that we have any "Session Manager" value at all.
- In an another link I found, http://forums.citrix.com/thread.jspa?threadID=265503, there it is another registry value they are refering to:
HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Quota System
Value name: EnableCpuQuota
Value meaning: A value of 0, is used to disable DFSS. A value of 1 is used to enable DFSS

(Here we have a value of 1)

I am a bit confused how I can be sure that our DFSS is disabled?
Kind Regards
/Anders
AKa68Asked:
Who is Participating?
 
Ayman BakrConnect With a Mentor Senior ConsultantCommented:
Disabling it from the registry should do it provided Turn off Fair Share CPU Scheduling is at least Not Configured. Should it be Disabled it might have the effect of overriding your registry setting and enabling DFSS.

Again I am saying 'might' because Microsoft admits that it is not functional and therefore being disabled might also be not functional - in which case, regardless of the GPO setting, the registry setting would reign.
0
 
Ayman BakrSenior ConsultantCommented:
The correct procedure should be to turn it off from GPO first (the first HKLM key provided in your question is the reflection of setting it off through the GPO; as you don't find it then it seems that you have not set it to off through GPO). Then you will have to do the value set in the second registry provided in your question.

See this CTX KB article:

http://support.citrix.com/article/CTX127135
0
 
AKa68Author Commented:
I am testing if it´s enough just to change the setting in the registry to disable the DFSS:

The dedicated DFSS registry key is:
Key name: HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Quota System
Value name: EnableCpuQuota
Value meaning: A value of 0, is used to disable DFSS. A value of 1 is used to enable DFSS.

Pasted from <http://forums.citrix.com/thread.jspa?threadID=265503>
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.