PSExec - Disable Auto Logon

I need to disable Auto Logon on a user's machine and am doing through PSEXEC.  What is the correct registry path to do this on?  Thanks.
itsmevicAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
David Johnson, CD, MVPConnect With a Mentor OwnerCommented:
Try this first:
psexec \\computername -u username -p password rundll32 netplwiz.dll,ClearAutoLogon

If this doesn't work then it is set in the registry

psexec \\computername -u username -p password reg delete HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon\ -v DefaultPassword
psexec \\computername -u username -p password reg add HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon\  /v AutoAdminLogon /t REG_BINARY /d 0 

Open in new window

0
 
SandeepConnect With a Mentor Sr System AdministratorCommented:
Have a look at this one.

http://answers.microsoft.com/en-us/windows/forum/windows_7-security/disabling-auto-login-for-windows-7-with-only-1/87e682b2-e038-4f23-927b-58bb9fe6f8ab

You can try using that registry or add that command in a batch file and using PSExec copy over that batch from your PC to remote PC and then execute the same.

PSExec commands are as below

http://technet.microsoft.com/en-us/sysinternals/bb897553.aspx
0
 
atsvirginiaCommented:
1. Start > then type netplwiz
2. Select the user account that's logging on automatically and check the “Users must enter a user name and password to use this computer"
3. click on the Apply button
0
 
SandeepSr System AdministratorCommented:
atsvirginia - Its required to change on remote PC not Local PC
0
 
itsmevicAuthor Commented:
Thank you!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.