Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 284
  • Last Modified:

WSUS connectivity

I have a non domain window 2003 sp2, and there is a domain connected WSUS (2k3 as well). Is it possible to push updates to the non domain windows server ? if so how can I do this ?
0
shadow2007
Asked:
shadow2007
3 Solutions
 
chichaoffCommented:
On you workgroup computers, run regedit to open registry editor, navigate to
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\windows\WindowsUpdate

You also need to create/configure the UseWUServer registry value in the subkey
HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU with dword:0x1

in order to cause the WUAgent to read the other two values (WUServer and WUStatusServer). If UseWUServer is absent, or false, the WUAgent will continue to update from Automatic Update (if configured to update at all).

Configure WUServer and WUStatusserver as the URL of your WSUS server with the port number.

After configuring, run "wuauclt /detectnow" to force the communication.
Reply  Quote
0
 
AnthonyHamonCommented:
This is possible.  As your Windows Server 2003 machine is not on the domain, you need to configure AU using Local Group Policy, as follows:

Run gpedit.msc
Open the User Configuration branch of the tree
Right-click Administrative Templates and select Add/Remove Templates
Select wuau and click Add.  Click wuau.adm in the Policy Templates dialog box and click Open
To view all the AU configuration policy options in the Group Policy Object Editor, go to Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update
Select 'Specify intranet Microsoft update service location' and specify the address of your WSUS server
Amend any of the other AU policy settings, as required
Restart your server
Run wuauclt /detectnow
Check the C:\Windows\WindowsUpdate.log file to ensure that the server was able to connect to your domain based WSUS server
0
 
SandeepSr System AdministratorCommented:
You have to set Local GPO for that machine.

You can access it through gpedit.msc as advised above.

Go to Computer Configuration->Administrative Templates->Windows Components->Windows Update

Over here you will find several values in which there are few important which requires to be set. There are others too but below are important, if Configure Automatic Updates is set to disabled, even after providing WSUS IP, server will not look to detect Windows Update.

Configure Automatic Updates - Enable this, and select default option 3 Auto Download and notify for install.
Specify intranet Microsoft update service location - Provide WSUS Server IP as http://ServerIP

Once this one is done, reboot your PC.
Run command wuauclt /detectnow - This will detect new patches from WSUS Server.
wuauclt /reportnow  - This will report the status to the WSUS Server about patches.

Hope this Helps.
0
 
McKnifeCommented:
...and if you don't want to reboot your server (which I can imagine), simply restart your update service to enable the new settings. wuauclt /detectnow alone will not do this, by the way.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now