Solved

online

Posted on 2013-01-31
11
213 Views
Last Modified: 2013-02-28
I cannot go online...

in my linux machine in my other machine with same configuration it is working fine..
I did everything same configuration..I checked everything
but I cannot go online...
screen shot attached...
net.png
0
Comment
Question by:walkerdba
  • 5
  • 4
  • 2
11 Comments
 
LVL 23

Expert Comment

by:savone
ID: 38841429
We will need more information to help.

Are you using DHCP or Static IP address?
Are you using a proxy server?

Cat you post the output of the following commands:

cat /etc/sysconfig/network-scripts/ifcfg-eth0
cat /etc/sysconfig/network
cat /etc/resolv.conf

That is a good start.
0
 

Author Comment

by:walkerdba
ID: 38841737
[root@term ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
DEVICE=eth0
BOOTPROTO=none
BROADCAST=192.168.2.255
HWADDR=00:0C:29:FE:8B:5F
IPADDR=192.168.2.45
IPV6_AUTOCONF=yes
NETMASK=255.255.255.0
NETWORK=192.168.2.0
ONBOOT=yes
TYPE=Ethernet
[root@term ~]#

[root@term ~]# cat /etc/sysconfig/network
NETWORKING=yes
NETWORKING_IPV6=yes
HOSTNAME=term.localdomain
[root@term ~]#


[root@term ~]# cat /etc/resolv.conf
nameserver 192.168.0.1
search hsd1.ca.comcast.net.
[root@term ~]#
0
 
LVL 23

Expert Comment

by:savone
ID: 38841951
Your DNS is set to 192.168.0.1 which is a different subnet that your IP address.  

try this:

ping 192.168.0.1

and post the results.
0
Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

 

Author Comment

by:walkerdba
ID: 38842438
[root@term ~]# ping 192.168.0.1
connect: Network is unreachable
[root@term ~]#
0
 
LVL 17

Expert Comment

by:Sikhumbuzo Ntsada
ID: 38842743
Can you also post the config of the working box.

As the expert says, this box needs to be on the same network as the DNS + Gateway.

See an example of my box

[root@ewok ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
BROADCAST=172.16.255.255
IPADDR=172.16.1.46
NETMASK=255.255.0.0
NETWORK=172.16.0.0
GATEWAY=172.16.1.39
ONBOOT=yes
TYPE=Ethernet

Your current setup will work if you have a router in between your two networks, even then, you still need to change a few things.
0
 

Author Comment

by:walkerdba
ID: 38843021
# Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
DEVICE=eth0
BOOTPROTO=none
BROADCAST=192.168.2.255
HWADDR=00:0C:29:FE:8B:5F
IPADDR=192.168.2.45
IPV6_AUTOCONF=yes
NETMASK=255.255.255.0
NETWORK=192.168.2.0
ONBOOT=yes
TYPE=Ethernet
~                                                                              
~                                                                              
~                                                                              
~                                                                              
~
0
 
LVL 17

Expert Comment

by:Sikhumbuzo Ntsada
ID: 38843051
Can you successfully ping another machine on your network?
Is there a firewall ?
0
 
LVL 23

Expert Comment

by:savone
ID: 38843754
One the working machine, post the output of the following three commands:

ping 192.168.0.1

dig google.com

route -n
0
 

Author Comment

by:walkerdba
ID: 38860636
# Advanced Micro Devices [AMD] 79c970 [PCnet32 LANCE]
DEVICE=eth0
BOOTPROTO=none
BROADCAST=192.168.2.255
HWADDR=00:0C:29:FE:8B:5F
IPADDR=192.168.2.45
IPV6_AUTOCONF=yes
NETMASK=255.255.255.0
NETWORK=192.168.2.0
ONBOOT=yes
TYPE=Ethernet
~                                                                              
~                                                                              
~                                                                              
~                                                                              
~                                                                              
~                                                                    



Machine is pinging with public address  no issues

but with DNS

[root@term network-scripts]# ping 192.168.0.1
connect: Network is unreachable
[root@term network-scripts]#
0
 
LVL 23

Accepted Solution

by:
savone earned 500 total points
ID: 38860907
I dont understand you last comment, can you please post the output of the following commands run from the working machine:

ping 192.168.0.1

dig google.com

route -n
0
 

Author Closing Comment

by:walkerdba
ID: 38938641
yes
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
This video shows how to use Hyena, from SystemTools Software, to bulk import 100 user accounts from an external text file. View in 1080p for best video quality.
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question