Solved

Server 2012 WSUS 0x80244019

Posted on 2013-01-31
27
6,904 Views
Last Modified: 2016-02-21
Having a nightmare of a time getting server 2012 to run WSUS. The Roles ext install fine but after configuring the server with my usual WSUS GPO no machines can connect. Here is a sample of the log and any ideas would be welcome:
log.txt
0
Comment
Question by:Dead_Eyes
  • 14
  • 10
  • 3
27 Comments
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
In your WSUS GPO are you specifying to use port 8530 ??? <<<Most likely you should be
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
0
 

Author Comment

by:Dead_Eyes
Comment Utility
Thanks for the quick reply. Yes I have specified port 8530 in the GPO and I have looked at the self update folder (rebuild the server 3 times with no luck suggesting that its something extra you have to do in 2012 as running the setup and config does not seem to be enough)
0
 
LVL 53

Expert Comment

by:McKnife
Comment Utility
Hi.

Please make sure that you can telnet into port 8530.
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
Next, temporarily disable firewalls
0
 

Author Comment

by:Dead_Eyes
Comment Utility
Looking into how you test with telnet and firewalls are already disabled
0
 

Author Comment

by:Dead_Eyes
Comment Utility
Here are the results of the client diagnostic tool
client.png
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
Clientdiag does not work on 64Bit systems
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
This may or may not help

http://support.microsoft.com/kb/959894
0
 
LVL 53

Expert Comment

by:McKnife
Comment Utility
About telnet: procedure to install (at the client): see http://technet.microsoft.com/en-us/library/cc771275(v=ws.10).aspx
Command to execute at the client after installation:
telnet NameOfWsus 8530
The outcome will show you if that port can be "talked to" or not.
0
 

Author Comment

by:Dead_Eyes
Comment Utility
Telnet servername 8530 seems to execute ok put just hangs there with a flashing prompt. Don't know if this indicates its working or not?
0
 
LVL 53

Expert Comment

by:McKnife
Comment Utility
If the command shell clears, it tells you it's working, so that's not the problem here.
Can the server itself receive updates to install?
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 

Author Comment

by:Dead_Eyes
Comment Utility
yeah services are fine and machine is clean. :(
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
Double check your WSUS GPO and ensure that you have your "Specify intranet....." settings correct

a spelling mistake or even a "Space" can make a difference
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
At a client, what are the results of ???


reg query HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate /s

from a cmd prompt
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
From your log "http://WIN2K12WSUS/selfupdate/wuident.cab"


We can see that your GPO is incorrect

it should be reading "http://WIN2K12WSUS:8530/selfupdate/wuident.cab
0
 

Author Comment

by:Dead_Eyes
Comment Utility
In my experience group policy assumes a port of 8530 but just to be sure I amended the gpo and re-tested but still same error.

Please find the results of reg query HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate /s attached

The specify intranet settings are correct but I do not expect the GPO settings to be the issue I as use this same policy on many sites and it works 100% every time
Untitled.png
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
"In my experience group policy assumes a port of 8530"?????



Absolutely not!!!

Again, from your screenshot you can still see the 8530 is missing and this needs to be added in order for the client to communicate correctly with WSUS.

Error 0x80244019 is always the result of network disruption
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
From....

http://technet.microsoft.com/en-us/library/hh852346.aspx

WSUS 3.0 uses port 80, by default. However, in Windows Server 2012, by default WSUS 4.0 uses port 8530.

When you type the intranet address of your WSUS server make sure to specify which port is going to be used. By default WSUS will use port 8530 for HTTP and 8531 for HTTPS. For example, if you are using HTTP, you should type http://servername:8530.
0
 

Author Comment

by:Dead_Eyes
Comment Utility
Sorry for late reply but had to fit in some weekend and do some testing. I have addpreped the domain by adding a DC running 2012 and checked IIS (confirmed my 2012 WSUS server is on port 8530 as I thought). I have specified 8530 in the GPO and all servers have been run gpupdate /force and rebooted. Still the same error though. I have even tried editing the registry and specifying http://win2k2012wsus:8530 . I have attached the latest windowsupdate.log entry
log.txt
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
Again from your log

784      EP      Got WSUS Client/Server URL: "http://WIN2K12WSUS/ClientWebService/client.asmx"
2013-02-04      14:21:46:769       828      784      Setup      Checking for agent SelfUpdate
2013-02-04      14:21:46:769       828      784      Setup      Client version: Core: 7.8.9200.16465  Aux: 7.8.9200.16451
2013-02-04      14:21:46:769       828      784      EP      Got WSUS SelfUpdate URL: "http://WIN2K12WSUS/selfupdate"

You can see that "8530" is not there
0
 
LVL 47

Expert Comment

by:dstewartjr
Comment Utility
have you tried using RSOP.msc to see if there is another GPO conflicting??
0
 

Author Comment

by:Dead_Eyes
Comment Utility
I have reviewed RSOP and policy is applied specifying 8530 with no conflicts
0
 

Author Comment

by:Dead_Eyes
Comment Utility
Looking through logs from other sites I cannot see the port mentioned are you sure it should be?
0
 
LVL 47

Accepted Solution

by:
dstewartjr earned 250 total points
Comment Utility
POSITIVE!

Server 2012 WSUS uses port 8530 by default.

From within the WSUS console you can see which port WSUS is using.8530
0
 

Author Comment

by:Dead_Eyes
Comment Utility
Got it, it may well be coincidence but ever since I created the 2012 DNS, DC the other 2008 Servers started seeing the wsus server and then when I Deleted the group policy (the 2 groups of servers used different GPO’s but same WSUS settings) and recreated it.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Every now and then, Microsoft does something that totally impresses me. It doesn't happen often, but in this case I must say I am thoroughly impressed with Windows Server Backup. One of the long time issues with Windows Backup has been the ability t…
The reason that corporations and businesses use Windows servers is because it supports custom modifications to adapt to the business and what it needs. Most individual users won’t need such powerful options. Here I’ll explain how you can enable Wind…
In this Micro Tutorial viewers will learn how they can get their files copied out from their unbootable system without need to use recovery services. As an example non-bootable Windows 2012R2 installation is used which has boot problems.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now