?
Solved

add Datastore failed with HostDatastoreSystem.QueryVmfsDatastoreCreateOptions

Posted on 2013-01-31
11
Medium Priority
?
1,256 Views
Last Modified: 2013-02-07
Brandnew HP Proliant 350p G8 with SAS 421 and SD Media Card
vmWare ESXi 5.1 installed on internal SD
all components from HP and an HCL

After installation of ESXi when i want to add DataStore, for the first Array I have allways a error Message:
"HostDatastoreSystem.QueryVmfsDatastoreCreateOptions" for Objekt "ha-datastoresystem" auf ESXi "192.1....

It is no Problem to add the Second Array ...
I found a comment, but no solution.    
http://www.experts-exchange.com/Software/VMWare/Q_27709842.html 

Is there only this Workaround ... an no solution?
0
Comment
Question by:perolin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 123
ID: 38841437
there is no partition or data on the array?
0
 
LVL 2

Author Comment

by:perolin
ID: 38841449
brand new and empty.

after first problem, i deleted array, replaced physical disks, build new array. Same Failer.
0
 
LVL 123
ID: 38841476
its unclear from the referenced EE question, what the solution was

I would refer to HP.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 2

Accepted Solution

by:
perolin earned 0 total points
ID: 38846466
After ours with HP Support, BIOS and Firmeware Update, Resets and x10 boot and trails, lots of hints how to handle this with SSH on ESXi Host with commands like fdsik –l …  dd if=/dev/zero …  partedUtil mklabel … I quit.

I removed the SD Card from motherboard, installed ESXi on physical Disc and everything works fine!

I assume, that the Installation of ESXi on SD Card has a problem to use LUN 1. There is also to make one setting for the scratch path, that’s ok. But to not have access to LUN 1 (the drive seems to be read only for ESXi).

Configuration used: HP Proliant ML350p Gen8, BIOS 2012-12-14, Smart Array P420i Ver 3.22 with SAS SFF Discs, SD Card on Motherboard Slot, HP ESXi Image 5.1.0 Build-799733 HP 5.32.5
0
 
LVL 2

Author Comment

by:perolin
ID: 38846471
Maybe HP will provide a solution, and then I will post it.
0
 
LVL 123
ID: 38846514
this error is usually because there is a partition already in use. HP provided you with instructions to try and delete it, very odd indeed. So it would seem that HP do not have a solution either ... yet!
0
 
LVL 2

Author Comment

by:perolin
ID: 38848496
hanccocka: this error is usually because there is a partition already in use.

and this happens while ESXi is installed on SD Card. HP or vmWare?
0
 
LVL 123
ID: 38848692
Correct. ESXi/ESX cannot handle creating partitions on some disks, e.g. the removal.
0
 
LVL 2

Author Closing Comment

by:perolin
ID: 38863255
Ours of trails with HP Support.
0
 
LVL 2

Author Comment

by:perolin
ID: 38865389
It Works!  Together with HP Support we found a solution.  The Problem was definitely that the SD Installation of ESXi was at LUN 1.
With HP Intelligent Provisioning 1.3 for Proliant G8 it works fine. On Server delivered in January there is only Release 1.0 .  Intelligent Provisioning will not be update with HP SPP 2012-10.  Download HP Intelligent Provisioning for this update.  

During VMware ESXi installation, perform the following:
Boot the server using bootable VMware image disc by selecting to boot from CD/DVD drive. Follow on-screen instructions.
At the option/screen, select a Disk , select HP iLO LUN 00 Media 1 (mpx.vmhbaXX:C0:T0:L0) which has 3.74GB capacity VMFS partition and proceed with on-screen instructions.
0
 
LVL 123
ID: 38865491
Thanks for the feedback.
0

Featured Post

10 Questions to Ask when Buying Backup Software

Choosing the right backup solution for your organization can be a daunting task. To make the selection process easier, ask solution providers these 10 key questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
In this article we will learn how to backup a VMware farm using Nakivo Backup & Replication. In this tutorial we will install the software on a Windows 2012 R2 Server.
Teach the user how to convert virtaul disk file formats and how to rename virtual machine files on datastores. Open vSphere Web Client: Review VM disk settings: Migrate VM to new datastore with a thick provisioned (lazy zeroed) disk format: Rename a…
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question