• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2365
  • Last Modified:

Google Chrome won't accept local file cookies

I'm trying to get Google Chrome on my Win7 computer to accept and read local file cookies for HTML pages on my hard disk.

I have so far been unsuccessful at getting Chrome to work properly with either the "--allow-file-access-from-files" option or the "--enable-file-cookies".

I right-click on the Chrome icon, choose properties, and then modify the target to add the command-line option to the end (after a space):

C:\Users\Tim\AppData\Local\Google\Chrome\Application\chrome.exe --enable-file-cookies

Save the shortcut, close all browsers, then open Chrome with this shortcut and paste in the local C:\DocDir\index.htm file in the URL window and the cookies are not saved.

Any ideas what I'm doing wrong?  Or did Google remove this option?
0
Tim Titus
Asked:
Tim Titus
  • 2
1 Solution
 
Dave BaldwinFixer of ProblemsCommented:
This document from Google http://code.google.com/p/browsersec/wiki/Part2#Same-origin_policy_for_cookies shows in the chart that Chrome does not support cookies for file URLs.  The probability is that other browsers will follow suit after a while because security restrictions just keep getting tighter.
0
 
Tim TitusCTOAuthor Commented:
Well described, good article presented.
0
 
Dave BaldwinFixer of ProblemsCommented:
Thanks and thanks for the points.
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now