Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

3TB size problem

Posted on 2013-01-31
14
Medium Priority
?
1,625 Views
Last Modified: 2013-02-01
Hello people,
I'm a little confused.

The problem is that I see only 750GB on each hard drive.

I have a SuperMicro Server http://www.supermicro.com/products/motherboard/xeon3000/x58/x8sti-f.cfm

I have 4 3TB HDD's (HDD-T3000-ST33000650NS      Seagate)

The HDD's are in the Tested HDD List.
The MB has ICH10R and Embedded Adaptec. (Same result on both)
 
I have updated the       IPMI Firmware and BIOS.

Is there anything I can do to see more then 750GB??

Thanx,
Alex
0
Comment
Question by:Javin-Miles
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
  • +3
14 Comments
 
LVL 47

Expert Comment

by:David
ID: 38842660
absolutely nothing other than change the controller.  Many older chipsets can't handle the modifications necessary.  (2.09TB is the max you can address with 32 bits worth of addressing, and firmware  updates on low-end embedded adaptec and fakeraid controllers won't do the job. it is a major rewrite of the code and not all controller chips have enough address bits.
0
 
LVL 10

Expert Comment

by:deviprasadg
ID: 38842661
Open diskmgmt.msc and check if there is any un formatted, un allocated, system reserved space on your hard disk.

Allocate the space if it is unallocated.

Referr: http://www.howtogeek.com/123268/windows-hard-drive-wrong-capacity/
0
 
LVL 96

Expert Comment

by:Lee W, MVP
ID: 38842857
Since I don't have this board, I cannot say for certain what your problem is.  It could be a BIOS/Hardware issue.  Or it could be an OS is - you didn't indicate WHERE it's telling you the drives are 750 GB (or so).  If it's in Windows, it's because you didn't configure them as GPT drives.  If it's out of Windows in BIOS then it could be a hardware/controller/firmware issue and there may be no resolution other than adding a newer controller.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 70

Assisted Solution

by:garycase
garycase earned 1000 total points
ID: 38842860
Well ....   my initial inclination was to agree with dlethe that there's nothing you can do except to get a controller that supports drives > 2TB.      Many controllers are in fact limited to a maximum size of 2TB (in "computerese", where 1KB = 1024B;   note that this is slightly more in "disk-drive-maker-ese", where 1KB = 1000B).

In the case of those controllers, what you're "seeing" is the "wraparound" of the actual space ... in technical terms you're seeing 3TB modulo 2TB (i.e. the remainder).     Your controller has 32-bits, but the number of logical block addresses in a 3TB drive doesn't fit in that ... so the higher-order bits are effectively just discarded.     The result is a reported 801GB (in "disk-drive-maker-ese"), which is 746GB in "computer-ese".    So the drive "looks" like a much smaller drive, due to the controller restrictions.

So ... that SOUNDS like the issue, UNTIL I looked a bit closer at both your system's specifications and your note that these HDs are on the tested HD list (which I confirmed).

Your system is certainly new enough that it SHOULD support 3TB drives;  and indeed several 3TB drives are listed in the tested HDDs list.

So ... a couple of questions:

(1)  What size is shown for these drives in the BIOS ??

(2)  Did you format them with GPT?    This is required for drives > 2TB.
0
 
LVL 56

Expert Comment

by:andyalder
ID: 38842976
Have you tried Seagate diskwizard? That partitions the disk into two in hardware so Windows can use them as C: and D: Will be restricted to having hardware RAID disabled though.
0
 
LVL 47

Expert Comment

by:David
ID: 38843255
Looking at partitiions is a waste of time as the controller makes decisions based on the overall capacity of the target device. It is simple, the total block count is > FFFFFFFFh bytes, which is all the controller can deal with because it uses a 32 bit number.   When your capacity is > FFFFFFFh blocks then capacity is calculated (improperly, but it has no idea) of capacity - 100000000 hex  blocks.
0
 
LVL 1

Author Comment

by:Javin-Miles
ID: 38843381
garycase,
I found it strange that I see 746GB, even though the HDs are listed in the tested HDDs list.
Anyway,
1. I have 746GB shown on POST and RAID config utility (Ctrl+i)
2. No, I did not format them with GPT.

How do I format them to GPT?

Do I have to format before I put them in my server?
0
 
LVL 47

Accepted Solution

by:
David earned 1000 total points
ID: 38843564
This is NOT a HD problem.  It is a controller limitation.  Look, the disks have > FFFFFFFF hex blocks, but the controller hardware/firmware uses 32-bit numbers.  You need 33 bits to hold your capacity.

Leading order bit is dropped by the CONTROLLER, so you see 3000GiB - 2090GB

There is a solution ... somebody could reprogram the disk so that they report they are 2GB in size instead of 3GB in size.  That way you can keep the hardware.

Or buy another controller.
0
 
LVL 96

Expert Comment

by:Lee W, MVP
ID: 38843639
If the RAID config tool claims they are 746 GB, then I would agree, this is a controller limitation.  The OPERATING SYSTEM is where you would format the drives as GPT.

This is why I asked where you were seeing this.
0
 
LVL 1

Author Comment

by:Javin-Miles
ID: 38843738
Thanx everyone.

Next stop...  4 SATA RAID w/3TB support

I still don't get why is the HDD listed in the tested HDDs list?  I have a thought that it is used with a different controller on the same MB from SuperMicro, but I've spent too much time already....
0
 
LVL 1

Author Closing Comment

by:Javin-Miles
ID: 38843742
Thanx)
0
 
LVL 47

Expert Comment

by:David
ID: 38843805
The HDD is listed because the HDD works just fine with controllers that support higher capacity.  You are making a quite common mistake, so don't feel bad.  Both the controller and HDD work perfectly independently.  Your issue is one of interoperability.

Take the disks back if this was all sold together by a reseller because they screwed you and didn't know better.  if you bought things separately, then get yourself a LSI MegaRAID that supports SAS2/SATA3 disks and you are assured it supports the larger capacity drives.  

But those older adaptec won't and the fakeraid intel controllers should be avoided at all costs anyway because they are absolute crap and all the RAID is done by a device driver anyway.

Reprogramming the disks is a band-aid and you'd have to pay somebody to do it, and even then you would have to buy 2TB drives to use as spares forever.   (You wouldn't be able to cost justify purchasing the software anyway and there is risk that those drives are locked to prevent changing capacity anyway ... hence suggestion just to pay somebody to do this for you).

An appropriate controller is the way to go.
0
 
LVL 56

Expert Comment

by:andyalder
ID: 38844146
Seagate diskwizard is not a waste of time. it just doesn't work alongside a RAID controller. The partitions are hard partitions so the 2TB boundary does not need to be crossed.

>I still don't get why is the HDD listed in the tested HDDs list?
Because it works perfectly if you use diskwizard with RAID on the motherboard turned off.
0
 
LVL 1

Author Comment

by:Javin-Miles
ID: 38844199
Thank you Experts
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question