Solved

Microsoft Excel opens slowly when Trend Worry Free/Micro Security Agent is Enabled

Posted on 2013-02-01
4
1,169 Views
Last Modified: 2013-11-22
We recently changed over from McAfee to Trend.  Excel opens slowly on my computer; regardless of opening a file to open Excel, or simply opening the program.

When I disable Trend, Excel opens at normal speed.

I've tried adding an exception to the path of Excel, as well as XLS and XLSX file types.  I've also added it to a trusted program.  No luck.  When I close Trend, Excel opens fine.  Any suggestions?

I think it may be an add-in, however, I am unable to determine the add-in path or extension to exclude.
0
Comment
Question by:spaethg000
  • 3
4 Comments
 
LVL 16

Assisted Solution

by:terencino
terencino earned 500 total points
Comment Utility
Hi, this was the main reason we moved away from Trend! It is possible the patch or hotfix noted here at Trend might resolve the problem. But probably not.
Worry-Free Business Security (WFBS) 7.0 issues that will be resolved by Critical Patch Build 1370
Before moving away from Trend I had the administrator turn off the scan engine during work hours. It defeated the purpose though so we moved to Panda, then Sophos, and now GFI Managed Antivirus.
Hope that helps
...Terry
0
 

Author Comment

by:spaethg000
Comment Utility
I saw that link, but that's for version 7.  I'm already on version 8.  I continue to search for a solution.   Thank you though!
0
 

Accepted Solution

by:
spaethg000 earned 0 total points
Comment Utility
This solution improved Excel performance by 50%:

1. Unload the WFBS Security Agent.
2. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TmFilter\Parameters\
3. Right-click on Parameters > New >DWORD Value
4. Rename the Binary Value from New Value #1 to ExcelSDT
5. Set value: 64 in Hexadecimal base
6. Check the save result, should display 0x00000064 (100)
7. Reload the Security Agent
8. Wait for 1-2 minutes for setting deploy.
9. Try to save Excel files and check if you have the same issue.

This second registry tweak brought performance levels near or at normal:

1. Unload WFBS Agent
2. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TmFilter\Parameters\
3. Locate the REG_DWORD --->  AvoidExcelSaveIssue 4. Right-click on it and choose "modify"
5. Change the value from "1" to "0"
6. Reload the Security Agent
7. Wait for 1-2 minutes for setting deploy.
8. Try to save Excel files and check if you have the same issue.
0
 

Author Closing Comment

by:spaethg000
Comment Utility
My solution solved the issue. :)
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

A little background as to how I came to I design this code: Around 5 years ago I designed an add-in that formatted Excel files to a corporate standard, applying different cell colours and font type depending on whether the cells contained inputs,…
This tutorial explains how to create a series of drop-down lists that are dependent upon prior selections to guide (“force”) the user to make the correct selection and reduce data errors within Microsoft Excel. Excel 2010 was used for this tutorial;…
The viewer will learn how to use the =DISCRINV command to create a discrete random variable, use this command to model a set of probabilities and outcomes in a Monte Carlo simulation, and learn how to find the standard deviation of a set of probabil…
This Micro Tutorial will demonstrate on a Mac how to change the sort order for chart legend values and decrpyt the intimidating chart menu.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now