Solved

Remote Desktop Connection Manager Error 50331661

Posted on 2013-02-01
9
9,764 Views
Last Modified: 2013-02-28
I am trying to use RDC Manager to connect to a terminal server via a remote desktop gateway.  Everything was working just fine until I changed the terminal servers IP address.  Now I am getting an Error 50331661.  Anyone have any idea what this error is? I haven't been able to find anything online.  

Trying to make connection from a Windows 7 machine to a server 2008 R2 RDP GW then to a server 2003 TS.
0
Comment
Question by:Infamous_Q
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
9 Comments
 
LVL 4

Expert Comment

by:AnthonyHamon
ID: 38844897
First of all, check whether you are able to make a RDP connection from the Remote Desktop Gateway server to the Windows Server 2003 server.  If not, there may be a firewall (or similar) blocking the access
0
 
LVL 2

Author Comment

by:Infamous_Q
ID: 38857387
Sorry for the delay in my response.  I am able to use a regular RDP sessions to make the connection.  But when I try to open the connection in RDCMan then it gives the error.
0
 
LVL 1

Expert Comment

by:George Hanel
ID: 38866074
Hi, just sorted a situation pretty similar to yours.

On windows 8, connecting to 2008R2 server, through 2008R2 gateway.  Works fine through RDP but was giving the same error using RCDMan.

I use proxy servers in schools and normally set it through internet options, lan settings.  Sometimes (noticed it since windows 8 so might not apply to 7) I have to set a proxy server on WinHTTP - to use windows store from inside a school.  I open powershell with admin rights, then following comands
netsh
winhttp
show proxy

If this isn't correct - ie shows "Direct access (no proxy server)" or the proxy server you may have to use - then this is probably your issue.  Basically it appears RDP uses settings from internet options, RCDMan uses settings from WinHTTP.

The following commands will replace the WinHTTP settings with what you have in Internet Options

netsh
winhttp
import proxy source=ie

If not proxy server have a look through WinHTTP related settings and look for incorrect settings.
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 2

Author Comment

by:Infamous_Q
ID: 38866159
Thanks for the reply, however this didn't fix the issue. I did look around in WinHTTP but didn't see any settings that were different from My normal IE settings.  No proxy is set in either IE or WinHTTP. I really have no idea why it can't connect.  Its pretty much a straight shot until you hit the firewall.   However that raises a question just now.  Can RDCMan use RDP protocol 8?  I am using a different port than the normal port 443 for the connection.  I know that I had to update my windows RDP client to handle the port change.  Would this be the same for RDCMan?
0
 
LVL 1

Expert Comment

by:George Hanel
ID: 38866226
How have you changed your client to connect to port 8 on RDP?  Is it the gateway that listens on port 8 or is it the end computer that listens on port 8?  Are the gateway or end computer (the one that isn't on 8) listening on their standard ports ie 443 if the gateway, 3389 if the end computer?

In the original post you said you changed your terminal servers IP...was this the internal or external IP?
0
 
LVL 2

Author Comment

by:Infamous_Q
ID: 38866244
the firewall listens on port XXX then forwards the traffic to port 443 on the gateway.  Everything else is set up pretty standard internally.  To be able to use port XXX from the outside we had to update the windows RDP client to use RDP protocol version 8.  Otherwise it would only use the standard port 443 for the gateway connection.  What I'm wondering is if RDCMan is able to use a gateway that is not on port 443.
0
 
LVL 1

Accepted Solution

by:
George Hanel earned 500 total points
ID: 38867276
Just tried it.  If you set your gateway to gatewayfqdn:8 in rcdman where 8 is your external port number on the firewall that redirects to 443.

This worked for me.
0
 
LVL 2

Author Comment

by:Infamous_Q
ID: 38869425
I will check my configurations and try again once I'm offsite.  Thanks!
0
 
LVL 2

Author Comment

by:Infamous_Q
ID: 38940029
Sorry for the delay in my response.  I checked my settings and I guess that I had forgot to include the port number, but all is working well.  thank you all for your help.
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Microsoft has released remote PowerShell capabilities to all commercial Office 365 customers. So you can be controlled via PowerShell and not from the Office 365 admin center Download Windows PowerShell Module for Lync Online http://www.micros…
Many companies are making the switch from Microsoft to Google Apps (https://www.google.com/work/apps/business/). Use this article to learn more about what Google Apps has to offer and to help if you’re planning on migrating to Google Apps. It is …
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…
The viewer will learn how to create two correlated normally distributed random variables in Excel, use a normal distribution to simulate the return on different levels of investment in each of the two funds over a period of ten years, and, create a …
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question