Solved

Problem with Microsoft IME on Published Microsoft Word 2010

Posted on 2013-02-01
9
2,464 Views
Last Modified: 2013-02-24
Hello,

We have a Windows 2008 R2 Application Server running Citrix XenApp 6.5 Rollup 1 with Microsoft Office 2010 32-bit.

One of the users need to type in Japanese using regular IME conversion. This feature works perfectly in Excel, PowerPoint, Notepad, or any other application but Microsoft Word. In Outlook, this works perfectly in any field you type but, of course, not when you create a new message since Word is the default editor.

When I say the feature doesn't work perfectly, I mean that it doesn't happen in a seamless way. Every time you type in Word using IME a gray sidebar appears with the japanese characters being converted. When you press ENTER, the characters are transferred to the document.

This only happens in Word and only in the published app window. If I log on the server and use Word locally, this doesn't happen and the typing is seamless. Word is installed with full feature set.

These are screenshots showing the problem:

1. Published App
http://gyazo.com/1a89fe4a78da820b74df67f09fda580c
 
2. Local Environment
http://gyazo.com/50118605ff1507abc64d2b9bd80860a0


Any ideas on what this can be related to?

Thank you!
0
Comment
Question by:birenshukla
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 38845487
It looks like there is a kind of setting that can toggle this on/off.

I found this link that might be helpful on the issue:
http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/japanese-ime-with-windows-7/5917ab33-00a1-498e-ba5f-6b51a8afce6b
0
 

Author Comment

by:birenshukla
ID: 38845491
Mutawadi,

Thank you for your reply. I can change the input type without any issues - and actually what I was using was Hiragana. The problem is that side bar that appears while I am typing. This only happens on the published app window. If I log on locally on the server with the same user it works perfectly fine. And, again, it is only in Microsoft Word.
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 38845580
If you have set a TS profile, then logging on locally with the same user, will actually log with a different profile. I am sure, there is a setting within the profile which is causing this behaviour. The side bar should be programmatically developed, otherwise it will never appear that way; i.e. it is not a kind of error. Hence, when I said that there must be a setting which can toggle it on/off. Perhaps you can check it as follows (I am not sure because I don't have it):

On the IME Language Bar click on Tools > Properties > On the IME properties go to the 'Editing' tab and check for any setting that can toggle this off. If you can't find it, then check it in the 'Conversion' tab (basically check all tabs).
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:birenshukla
ID: 38845590
Mutawadi,

Thank you again for your reply. In our environment, both Profile and RDS Profile point to the same profile folder. We did, however, copy the local profile to make sure this wasn't profile related. We double checked all settings on IME to match exactly the same settings we have when it works properly.

I may be wrong, but if this was related to IME shouldn't it happen to all the applications instead of only Microsoft Word?

Again, thank you!
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 38845623
I may be wrong, but if this was related to IME shouldn't it happen to all the applications instead of only Microsoft Word?
That might seem logical, however you need to consider how the IME is working in the background (perhaps keeping different setting customizations for different applications!); or maybe there might be a kind of conflict with a certain application causing the 'ill-behaviour'.

I can't be of more assistance. Hope somebody might come with a valuable input.
0
 

Author Comment

by:birenshukla
ID: 38891283
Over the past weeks we could narrow down exactly where the problem was. The responsible for displaying the "Finalize String" box is the Language Bar, not Microsoft Office. The reason it only happens on Microsoft Word is unclear.

We were able to reproduce the problem on a test account, which was fixed after the profile was created again from scratch and the Japansese language was added to Word 2010 after the Keyboard and IME are added. However, performing the same steps on the user's account did not work.

We contacted Microsoft and I will provide updates here as we make progress.
0
 
LVL 23

Expert Comment

by:Ayman Bakr
ID: 38895099
Just as I expected; Word was not to be blamed here. Good luck in your quest!.
0
 

Accepted Solution

by:
birenshukla earned 0 total points
ID: 38907377
After talking to Microsoft about the problem we were finally able to get this resolved. This is what you need to get this fixed:

- Log on under the user affected
- Make sure the Japansese Keyboard is installed on Regional Settings and the Language Bar is being displayed
- Open C:\Windows\regedit.exe
- Navigate to HKEY_CURRENT_USER\Software\Microsoft\CTF
- You should see a REG_DWORD – “Disable Thread Input Manager” with a value = 1. If the key doesn't exist, create it.
- Change the value of the DWORD to "0"

We found out that if the language bar is not active when changing the registry key and logging off the “Disable Thread Input Manager” DWORD value will reset to 1.

Thank you Mutawadi for your replies.
0
 

Author Closing Comment

by:birenshukla
ID: 38922784
Microsoft assisted answer.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Excel trusted location cannot take UNC path. 1 93
Citrix XenApp 6.0 License Server Update not taking effect 6 72
Getting EventID 4625 logon failures 18 124
Printer Settings 3 127
If your vDisk VHD file gets deleted from the image store accidentally or on purpose, you won't be able to remove the vDisk from the PVS console. There is a known workaround that is solid.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question