Quickie. Why do I have to press "shift" when I click on my database to open it

Hi,

I was tinkering a few days ago and changed a fundamental part of my database.

Now, I am forced to press "shift" if I want to open my database in full design mode.

How do I reverse this change?
Patrick O'DeaAsked:
Who is Participating?
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Connect With a Mentor Database ArchitectCommented:
You need to check (select) the two options shown in the Image ...

1
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
Holding down Shift prevents (bypasses) the AutoExec macro from running AND prevent (bypasses) any StartUp form (in options) from opening.

So ... look at your Auto Exec macro.

mx
0
 
Jim Dettman (Microsoft MVP/ EE MVE)President / OwnerCommented:
You added an autoexec macro or a startup form in options.

Jim.
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
1
0
 
Patrick O'DeaAuthor Commented:
Nope!  There does not appear to be an autoexec.

..I attach the database!

(...all a bit embarrassing ... considering I put the restriction there and can't remember)

The "Mainmenu" is the first form used.
EnnisBudgetActuals.accdb
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
1
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
1
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
This code is running:

1
0
 
Patrick O'DeaAuthor Commented:
Thanks DatabaseMX,

I can see the code that is running from "MainMenu" but can't see why this is forcing my "shift" start that I asked about.

Am I missing something?? (I must be!)
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
Well ... for one thing,  that code is Maximizing the main form.  Of course, it's your choice to hold the Shift key down.

Is this causing you a problem ?  If you need to get in for dev work, then hold down Shift key to bypass that form opening, etc., and get to your objects in the Nav Pane, etc.

mx
0
 
Patrick O'DeaAuthor Commented:
mx,

I removed the maximise command.  But to little avail..

I have solved the problem by creating a new database and "importing" all the forms from the original.

Nonetheless I am baffled when I need to "shift" the original database.
(I do not need to "shift" the new database).
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
" But to little avail.."
Well, not sure what you mean by that?
The form will still open. You can stop that by the property 'Display Form' (image above) to None.  This will keep that form from opening.

Is this what you are trying to stop?

Sorry ... I'm not clear what the actual issue is.

You should not have had to create a new db in this case ...

All holding down the Shift key does is ... either bypass running an AutoExec macro (if present) and/or opening a Form specified in the Display Form property.
0
 
Patrick O'DeaAuthor Commented:
Let me try and clarify;

I have 20 databases. 19 behave in the same way.

To open each one of the 19  I simply click on the file and it opens with full view of;
 "File    Home   Create   External Data    Database Tools"

However, the problematic database only gives the "File  Home" options.

Why do I have to press "shift" when opening one database whereas the 19 other databases all do not require this.


(Does this help explain things?)
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
yes ... ok, let me take a look ....
0
 
Patrick O'DeaAuthor Commented:
That's it.

I was playing around with some of these options a couple of days ago.

Thanks again for all your help.
0
 
DatabaseMX (Joe Anderson - Microsoft Access MVP)Database ArchitectCommented:
Sure - you are welcome.
mx
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.