Windows XP sharing problem

I have a network of 5 Windows XP computers.  On 4 of them, I can access the shares 'remotely' from all the other computers.  On the 5th, I can't access it's shares from the other 4 even though it can access their shares.  My MacBook Pro and my Ubuntu 8.04 systems also can access the first 4 but not the 5th.

Computers A and B are XP Pro, C and D are XP Home, and E, the one with the problem, is XP Media Center.  A, C, and D bring up a login window (which doesn't do any good) when I try to access E but B just says Accessed Denied.  I can access the two web servers, IIS and Apache on machine E.  Just no file shares.

File and Printer sharing is turned on on all the computers and they all haves shares with security set to allow 'Everyone' to access the shared directories.  All of these computers have static IP addresses and NetBIOS is set to auto which should provide "NetBIOS over TCP".  I've looked at the 'Local Security Policy' listings and can't find any difference between E and A or B.  What can I do to find out exactly why access is being denied?
LVL 84
Dave BaldwinFixer of ProblemsAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Scott ThompsonConnect With a Mentor Computer Technician / OwnerCommented:
Follow this link to change the setting in gpedit.msc

http://www.theeldergeek.com/blank_password_network_access.htm

This will make it where you don't need a password to share VIA the network in XP.
0
 
Scott ThompsonComputer Technician / OwnerCommented:
Have you tried putting a password on the Media Center edition machine?
0
 
JohnBusiness Consultant (Owner)Commented:
Also, with XP Pro, you need to turn off Simple File Sharing (Folder Options). You might check this option on the Media Center computer.

Have you tried accessing E as:  NET USE Z: \\IP_of_PC_E\folder and what answer do you get. If this happens to work, then there may be a firewall in the way somewhere.

... Thinkpads_User
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
Dave BaldwinFixer of ProblemsAuthor Commented:
Putting a password on the main user allowed me to logon from other machines.  This is what I get with 'NET USE':  The same username and password that allowed me to logon did not work there.
net use
0
 
Scott ThompsonComputer Technician / OwnerCommented:
I believe you have to tell it username and password when using that command but I'm not sure. However, glad to hear the password idea worked!
0
 
JohnBusiness Consultant (Owner)Commented:
Here is a Microsoft Support article for Error 53.

http://support.microsoft.com/kb/822345

Also check firewalls once again just to be sure.

.... Thinkpads_User
0
 
Dave BaldwinFixer of ProblemsAuthor Commented:
Never mind on the NET USE.  I had the share name wrong.

As far as passwords, 3 of the first 4 computers do not have a password set and sharing is working fine.
0
 
Scott ThompsonComputer Technician / OwnerCommented:
Yeah, XP is strange like that.  If you use gpedit.msc you can disable require password for network share, but XP home does not have gpedit.msc. XP Pro does, but I don't know about MCE.
0
 
Dave BaldwinFixer of ProblemsAuthor Commented:
As for the file mentioned in the article, Netbt.sys, I have a newer version on that computer.
0
 
Dave BaldwinFixer of ProblemsAuthor Commented:
XP MCE does have gpedit.msc but it doesn't have quite all the same options.  Where would I "disable require password for network share"?  I don't see that anywhere.
0
 
JohnBusiness Consultant (Owner)Commented:
In the Media Center machine, right click on My Network Places and select Properties. That brings up a Window with the Network card in the window. Right click on the Network card and select Properties. Do you have Client for Microsoft Networks installed as well as File and Printer sharing (which you said you did have installed)?

Also try repairing TCP/IP on the Media Center machine.

.... Thinkpads_User
0
 
Dave BaldwinFixer of ProblemsAuthor Commented:
I have both of those installed and the settings are the same as on this machine.  What do you mean by "repairing TCP/IP"?
0
 
JohnBusiness Consultant (Owner)Commented:
Sometimes TCP/IP goes awry and can cause an Error 53 "cannot connect"

Here is the general TCP/IP Repair/Reset article from Microsoft.

http://support.microsoft.com/kb/299357

Read down the article for manually resetting TCP/IP.

... Thinkpads_User
0
 
Dave BaldwinFixer of ProblemsAuthor Commented:
I didn't have to reset TCP/IP.  I was hesitant about that because access to the two web servers on that computer worked fine.  

When I looked at disabling the blank password, I notice that the guest access right above it was disabled so I enabled it instead.  That made it so all but one of the computers could access the shares without a login.  Computer B still has a problem but I think that is it's problem and not the original problem with the Media Center computer.
0
 
Dave BaldwinFixer of ProblemsAuthor Commented:
On this computer, I have these listed under "Network Access: Named Pipes..." in Security Policy.

COMNAP
COMNODE
SQL\QUERY
SPOOLSS
LLSRPC
EPMAPPER
LOCATOR
TrkWks
TrkSvr

On the computer B that isn't cooperating, I have:

COMNAP
COMNODE
SQL\QUERY
SPOOLSS
LLSRPC
browser

But these are the same settings I have on a computer C which turns out to be XP Pro instead of Home and also on the MCE computer.

This may have to be a different question.
0
 
Thomas WERNHERConfiguration ManagerCommented:
Hi,

just a question, are all the computers in the same workgroup ?

Cheers
0
 
Dave BaldwinFixer of ProblemsAuthor Commented:
Yes, they are all in the same workgroup.  The only problem I have left is that computer B can only access shares on computer E thru a login while A, C, and D can access shares on E without a login.  My MacBook and my Ubuntu can also access computer E now too.
0
 
Thomas WERNHERConfiguration ManagerCommented:
ok,

what we use in some case at work is that we create the same account with the same password on each computer and use it to access the shares...

hope this helps !

cheers
T
0
 
Dave BaldwinFixer of ProblemsAuthor Commented:
At this point, I would just like to know why computer B acts differently than the others.
0
 
Dave BaldwinFixer of ProblemsAuthor Commented:
The other posts were good info but this is what lead to the solution even though it wasn't the exact solution.  The problem was that the entry above it was disabling guest access.  My problem with computer B will have to wait for another question.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.