Solved

Route across NIC's on same PC

Posted on 2013-02-02
33
771 Views
Last Modified: 2013-02-05
Hi, I have a Windows Server 2012 with 2 NIC's.  One is 192.168.1.31 and the other 192.168.1.51.

192.168.1.31 is connected to my router and has internet access etc.  I can also see this NIC (via ping) from all the other PC's on my network.

In addition, I have a standalone PC which is connected directly to the second NIC on my Server.  I am doing this because this is an Infiniband IPoIB adaptec which I need in order to have a super fast connection between this PC and the Server.

I can move files between the Server and the directly connected PC, but from the standalone PC, I can't see the rest of my network.

Is there a way for me to set the two NIC's on the server so that they pass data back and forth?  Or is there another way for that Infiniband connected PC to see the rest of my network?

Thanks!
0
Comment
Question by:Hammer8
  • 17
  • 11
  • 5
33 Comments
 
LVL 20

Expert Comment

by:agonza07
Comment Utility
1) Add another NIC to the workstation and make it part of your network.

2) Configure Windows 2012 as a router. Here's how to configure it on 2008, but should be pretty close to how to configure it in 2012.
http://gunnalag.wordpress.com/2012/03/01/setting-up-a-windows-server-2008-r2-as-a-router/
0
 

Author Comment

by:Hammer8
Comment Utility
Thank you!  That seems to have worked, but given now traffice can go either through the regular NIC or the fast Infiniband card, how do I data goes through the Infiniband card whenever possible?

Thanks again, Hammer8
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
To make sure I understand you have:


               /---- 192.168.1.31/24 --> all other PC's and the Internet
SERVER <
               \---- 192.168.1.51/24 --> Directly attached PC

If so, then what you need to do, and should have done to start with is change the IP addresses on the second NIC so that they are on a different IP  address.  That is something like:

               /---- 192.168.1.31/24 --> all other PC's and the Internet
SERVER <
               \---- 192.168.10.51/24 --> Directly attached PC

You need to change the IP address on the directly attached PC also.

Leave routing enabled on the server and set the default route on the Directly attached PC pointing to 192.168.10.51 (or whatever you change that address to.
0
 
LVL 20

Expert Comment

by:agonza07
Comment Utility
Yup, that is right. I didn't notice both server NICs were on the same subnet, you should change one of them out per giltjr.

Now as far as traffic goes, which option did you go with for the workstation. Add a second NIC or did you enable routing?
0
 

Author Comment

by:Hammer8
Comment Utility
giltjr, that is what my current setup looks like.

I can try what you are suggesting, but I don't know how to set the default route...I found this:

route -p ADD “network” MASK “subnet mask”  “gateway ip”, but I don't know which address is "network" and which address is "gateway ip".  I assume mask = 255.255.255.0

If I did this, does that mean my "Directly attached PC" will only have the infiniband adapter with NO other NIC's?

I ask because agonza07 suggests it's either I have two NIC's on the "Directly attached PC" or I only have the Infiniband adaptec and I setup routing on the server.  But I shouldn't have two NIC's and enable routing...

I want to confirm since I'm a novice at this.

Thank you.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
Default route is just another name for default gateway.

You have two NIC's in the server right?  That is the only device that should need it.

What OS is running on the "Directly attached PC?"  It appears to be Windows, so on the "Directly attached PC" when you change the network settings to point to the server IP address in the NEW subnet.

If should only need to have a single NIC in the  "Directly attached PC."
0
 

Author Comment

by:Hammer8
Comment Utility
Thanks, I will try that.  In the meantime (I'm in the middle of copying a bunch of stuff and can't stop it), this appears to work well too:

               /---- 192.168.1.31/24 --> all other PC's and the Internet
SERVER <
               \---- 192.168.1.51/24 --> Directly attached PC

                                     /--------192.168.1.81/24 - default gateway 192.168.1.1
Directly attached PC<
                                     \--------192.168.1.82/24 - default gateway 192.168.1.51

And I have routing turned on in the "Directly Attached PC" which is also running Server 2012.

Copy speed is good as well and so data is passing through the Infiniband adapter.

However, I do get a warning that I shouldn't have two gateways on the "Directly attached PC"

Is above a valid configuration?
0
 

Author Comment

by:Hammer8
Comment Utility
giltjr, please ignore my prior posting.

I set the NIC's up as you suggested and now, in my server, my second infiniband adapter is showing up as unidentified network.

under TCP/IP (v4), I have:

IP:  192.168.10.51/255.255.255.0.
Default gateway is empty and so are the dns entries

On the Standalone PC, I have just one NIC, the infiniband one and set to:

IP:  192.168.10.81/255.255.255.0
Default gateway is 192.168.10.51

dns entries are empty.

I find that I can no longer RDP into the standalone PC.

Thanks again.
0
 

Author Comment

by:Hammer8
Comment Utility
Just to clarify, I can't RDP in the to standalone PC from the other 192.168.1.x PC's, but I can from the Server with routing turned on.  I guess that make sense.

So, my only concern now is the 192.168.10.x adapter is showing up as unidentified network on the Server with routing and it's coming up as a Public Network on the standalone PC.

Thanks!
0
 
LVL 20

Expert Comment

by:agonza07
Comment Utility
From the other machines that need RDP access configure this route

Start -> Run -> cmd

Route add 192.168.10.0 mask 255.255.255.0 192.168.1.31

Or configure the route on your default gateway to point to the server for the 192.168.10.x network.
0
 
LVL 20

Expert Comment

by:agonza07
Comment Utility
Btw, if you can't RDP after that route addition, check the firewall since its being identified as a public network. You should be able to change the network type under Network Properties.
0
 

Author Comment

by:Hammer8
Comment Utility
Route add 192.168.10.0 mask 255.255.255.0 192.168.1.31 didn't seem to work, so maybe it's a firewall issue...I can live with only RDP'ing from the Server...if there is no easy solution.

However, on the standalone PC, I still can't get the internet...I have access to its files from the Server, but from the standalone PC itself, I can get the internet.

Thanks again for all your help!
0
 

Author Comment

by:Hammer8
Comment Utility
BTW, I changed the connect to "Private" using mmc - Local Computer Policy\Computer Configuration/Windows Settings/Security Settings/Network List Manager Policies
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
Do you have the Windows Firewall enabled on, the server, the "direct attached PC", or both?

Just to make sure you enter the command:

     route add 192.168.10.0 mask 255.255.255.0 192.168.1.31

on a PC in the 192.168.10.0/24 subnet that needs to RDP to the "direct attached PC.
0
 

Author Comment

by:Hammer8
Comment Utility
Maybe I didn't explain it correctly.  I can rdp from the server to the standalone pc.  But I cannot rdp from a machine on the 192.168.1.x network into the standalone pc.

What I can do is first rdp into the server and then in that session, rdp into the standalone pc.

I would ideally like to rdp directly into the standalone pc from any machine on the 192.168.1.x network and not just from the server.
0
 
LVL 20

Expert Comment

by:agonza07
Comment Utility
Configure your gateway to route 192.168.10.x traffic through your server. That should allow you to go out the Internet, and as long as you disable the firewall on the standalone pc you should also be able to RDP from the 192.168.1.x network.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:Hammer8
Comment Utility
I'm not sure how to do that.  I have an Actiontec router and under "Add Route" it asks me for the following:

Name:      eg., name of route as I can add multiple routes,
Destination:      ...
Netmask:      ...
Gateway:      ...
Metric:

Thoughts?
0
 
LVL 20

Expert Comment

by:agonza07
Comment Utility
Name: standalone pc
Dest: 192.168.10.0
Net mask: 255.255.255.0
Gateway: 192.168.1.31
Metric: 1
0
 

Author Comment

by:Hammer8
Comment Utility
hmmm.  I just tried that and I still don't have internet access from the standalone pc nor can I rdp into that pc from the rest of my network (aside from the server it is directly connected to).

I have also turned off the firewall on the standalone pc and I also tried added 8.8.8.8 and 8.8.4.4 as the dns servers on the standalone pc.
0
 
LVL 20

Expert Comment

by:agonza07
Comment Utility
Let's run some ping and traceroute commands to figure out what is going on.

Find a workstation that you can ping from the server. Let's say its 192.168.1.100 or whatever you find that responds back.

Run these commands on the standalone PC.

ping 192.168.1.100

tracert 192.168.1.100

Now from the workstation 192.168.1.100 run the same commands back to the standalone.

ping 192.168.10.81

tracert 192.168.10.81

Post back the results.
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
On the standalone PC did you define its default route/gateway as 192.168.10.51?
0
 

Author Comment

by:Hammer8
Comment Utility
On the standalone PC did you define its default route/gateway as 192.168.10.51?   YES

From the server (one where routing is turned on), I can ping 192.168.1.28

tracert 192.168.1.28 returns:

Tracing route to 192.168.1.28 over a maximum of 30 hops

1 <1ms      <1ms      <1ms     MMVM2-S2012 [192.168.10.51]
2   *             *              *          Request timed out.
...
30 *              *             *          Request timed out.
Trace complete

From 192.168.1.28

ping 192.168.10.81   -> sent 4, receive 4 - OK

tracert 192.168.10.81

Tracing route to SERVER2012 [192.168.10.81] over a maximum of 30 hops:

1         1ms            <1ms          <1ms           192.168.1.1
2          1ms              *                  1ms          MMVM2-S2012 [192.168.1.31]
3          2ms              1ms            1ms           SERVER2012 [192.168.10.81]
trace complete
0
 

Author Comment

by:Hammer8
Comment Utility
update - I find that I can rdp from 192.168.1.28 to the standalone pc 192.168.10.81 aka SERVER2012.  What I need to do is reference the pc by its ip address and not SERVER2012
0
 
LVL 20

Expert Comment

by:agonza07
Comment Utility
Add SERVER2012 to your local DNS if you have one and you should be set to resolve by name.

Now what about internet on that standalone? Is that working?

In order to get that working you'll need to enable NAT for that subnet. You mentioned you have an ActionTec router, can we have the model number?

I still think having the two NICs on that standalone would be easier. If your ActionTec router doesnt support NAT on another subnet, then you'll have to enable NAT on your Server, but this might present other problems for you.

Honestly, i suggest you enable that second NIC on that standalone. Remove the default gateway from the 192.168.10.X NIC, and just put in a static IP from the local network on that second NIC. You should have internet, routing will be local, and the infiniband will work properly.

Please look at the attached diagram for a better explanation.
Dual-NIC.pdf
0
 

Author Comment

by:Hammer8
Comment Utility
Much appreciated.  I will try with a second NIC.  Does this mean I need to turn off routing on the Main Server?
0
 

Author Comment

by:Hammer8
Comment Utility
And do I delete the route I added in my router?
0
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
Can you provide a stick drawing like:

               /---- 192.168.1.31/24 --> all other PC's and the Internet
SERVER <
               \---- 192.168.10.51/24 --> Directly attached PC

with what your current setup is?  A second in the Directly attached PC may cause you other problems depending on how it is accessing the SERVER.
0
 

Author Comment

by:Hammer8
Comment Utility
/---- 192.168.1.31/24 --> all other PC's and the Internet via a ethernet switch
SERVER <
               \---- 192.168.10.51/24 --> Directly attached PC via infiniband


                                      /---- 192.168.1.81/24 --> connected to ethernet switch
Directly attached PC <
                                     \---- 192.168.10.82/24 --> via infiniband

I also took out the route I added in the actiontec router and turned off routing in the SERVER.  Also on the network (192.168.1.3) is a NAS which is running a WINS server.  I don't know what that does, but figured I let you know in case it does matter.

Now, I have internet service on the Directly attached PC, BUT when I copy files, the data is no longer passing through the infiniband connector since I am only getting gigabit ethernet speeds.

Thanks.
0
 
LVL 20

Expert Comment

by:agonza07
Comment Utility
How are you passing data? Using name?

Hardcode your host file to point to the server's infiniband network. Do this from the standalone and also from the server. Have them point to each other. I know it's another step to make sure all is good, but it's better than double NAT'ing in my opinion.

C:\Windows\system32\drivers\etc\hosts

Read the instructions on the file. Your entries should like:

On server:
192.168.10.51    StandAlonePCName
192.168.10.51     StandAlonePCName.domain.com

Then on standalone
192.168.10.82    Server
192.168.10.82    Server.domain.com
0
 
LVL 20

Expert Comment

by:agonza07
Comment Utility
Once you do that flush out your DNS cache and try again

From command line, "ipconfig /flushdns"
0
 

Author Comment

by:Hammer8
Comment Utility
Do you know what the entries would be if I'm not on a domain?
0
 
LVL 20

Accepted Solution

by:
agonza07 earned 500 total points
Comment Utility
I believe "ipconfig /all" will show you any domain suffix in your network.

If no domain suffix is on there then just leaving the first entry should do.
0
 

Author Comment

by:Hammer8
Comment Utility
It works!!  Thank you for all your help!  Not only did you help me get the system working, but I also learned a great deal as well.  I very much appreciate your time.  Hammer8
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
not output on the show arp command 5 42
Cisco switch SVI 17 39
Old Cisco access point to act as Repeater 5 35
Extending  a subnet 9 34
We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
Don’t let your business fall victim to the coming apocalypse – use our Survival Guide for the Fax Apocalypse to identify the risks and signs of zombie fax activities at your business.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now