Solved

MOSS Sharepoint 2007 Mylinks stopped populating for users

Posted on 2013-02-04
4
616 Views
Last Modified: 2013-02-16
Just took over  a Sharepoint 2007 environment.  A little background, the My Links feature
where if a user is added as a member to a site the link is added to My Links in the top right was working.  We moved all the users to a new domain and I think that is when
it stopped working properly.  When we moved the user's to the new domain we ran this command on the MOSS server and in fact all the old My Links are listed for each user.

stsadm.exe -o migrateuser -oldlogin olddomain\username -newlogin new domain\user -
ignoresidhistory

When adding users to a site now the My Links is not updating. I've been looking around online for a while and have not been able to track down the cause.  One thing that is strange is on the DB server if I run the sql query from this artlicle it comes up with 20 records when I know there are many more than that:

http://msmvps.com/blogs/shane/archive/2007/11/21/finding-my-links-in-the-database.aspx

I've looked at the profile import and that seems to be running fine from what I can tell.
0
Comment
Question by:dmwynne
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 44

Expert Comment

by:Rainer Jeschor
ID: 38852828
Hi,

I think that your user import is not working as it should. If you get only that few records I assume that there are only old entries from the old domain in the user profile store.

Can you check that after migrating to a new domain, that the user profile import connection has been updated accordingly and that it is importing the new domain accounts?

HTH
Rainer
0
 
LVL 14

Author Comment

by:dmwynne
ID: 38852909
I did change the import connection to point to the new domain controller and it shows the profiles of the new domain not the old in the list.
0
 
LVL 14

Accepted Solution

by:
dmwynne earned 0 total points
ID: 38864046
I am not sure what is going on but I managed to atleast get the My Links to update  now.  I created a temp group for the project and then removed the users from the default members group that is created automatically when a new project is created.   I moved users to the temp group and waited for the profile sync to occur.  I set the sync to occur every minute to speed this up  I then removed the users from the temp group and added back to the default members group and it updated the My Links.  I am still at a loss as to why  can't query the database and see them anywhere but I'm not going to worry about that for now.
0
 
LVL 14

Author Closing Comment

by:dmwynne
ID: 38896168
Found answer on my own.
0

Featured Post

Revamp Your Training Process

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is a fairly complicated script that will install the required prerequisites to install SCCM 2012 R2 on a server.  It was designed under the functional model in order to compartmentalize each step required, reducing the overall complexity.  The …
Experts-Exchange users below are the steps you can follow to upgrade your Lync server to latest CU's or cumulative updates. Note: Perform it during non-production hours.   Step 1: Backup your lync and SQL server database. Follow below article: h…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Suggested Courses
Course of the Month6 days, 7 hours left to enroll

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question