Excel 2010 - Having external links automatically update

I can't seem to get external links to update automatically in Excel 2010.  When I open a dependent workbook without having the source workbooks (three of them) open, I want the system to either automatically update the links or prompt me to update them.  I do not want to have to go into the Data tab, click Edit Links, and then click Update Values.  But that's all I can get to work without having any of the source workbooks open.  I did have one of my source workbooks open and then opened the dependent workbook, and it did update my values then, but I shouldn't have to have any source workbooks open in order to update my dependent workbook.  I've tried the different options under the "Startup Prompt" option.  And I've played with the "Update links to other documents" and "Save external link values" under File, Options, Advanced, but can't get it to work.  I want it to work how it did in the older version where when I open a dependent workbook, I want it to stop and ask me if I want to update the links.  I could live with the system automatically updating my links as well, but I can't get either one to work.  I do have all my files saved in the new .xlsx format.  They came from an older version of Excel - not sure if that's part of my problem or not.  HELP!!!
esu4236Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
esu4236Connect With a Mentor Author Commented:
Here's what I ended up doing.  I had to go into File, Options, Trust Center, Trust Center Settings, Message Bar.  Then I had to select the option "Show the Message Bar in all applications..."  Then once I set my user Startup Prompt to "Let users choose to display the alert or not,"  I FINALLY got the prompt asking me if I wanted to update my links.  Geez - this sure is not documented well in Microsoft's Help.  Unless I'm missing something, this seems to be the way it works.  Anyone have any other last thoughts?
0
 
R_EdwardsCommented:
read this, it may provide some insite to your questions and help with the frustration.

http://office.microsoft.com/en-us/excel-help/control-when-external-references-links-are-updated-HP010342302.aspx
0
 
esu4236Author Commented:
This look like the same information from Help, which I've already looked at.  Still not helping.
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
esu4236Author Commented:
I can't ever get Excel to prompt me with the question of whether I want to update or not.  WHY???
0
 
esu4236Author Commented:
"You may be alerted by the Trust Bar whether to update the links" - not getting this.  Haven't seen the Trust Bar.
0
 
R_EdwardsCommented:
are you the only user of the workbooks?  if not then this is what may of happened

Don't ask to update links for this workbook, and let me control whether links are updated
Warning    This option affects all users of the workbook. If you choose not to update links, and not to prompt, users of the workbook will not know that the data is out of date.

1.On the Data tab, in the Connections group, click Edit Links.
2.Click Startup Prompt.
3.Select the option that you want.
Note   Even if you specify that Excel should not ask whether to update links, you will still be notified if there are any broken links.
0
 
esu4236Author Commented:
I am the only user.  I am trying to learn how this works, as I have to train on this feature next week.  

Here's what I have for my setting - "Let users choose to display the alert or not."  So why am I NOT seeing the trust bar??????????
0
 
esu4236Author Commented:
Is there something  I need to set differently in the Trust Center in order for the Trust Bar to appear????
0
 
esu4236Author Commented:
I finally got the Trust Bar to appear!!! I had to change one of my Trust Settings.  Now I'm going to test further.
0
 
R_EdwardsCommented:
ESU,
     Sorry i had to step away for a tad, once you set your trust to Ignore i believe it sees that as default.  yes odd that it is not in any help documentation.  Gald you got it to work, chaulk this up as a meme in your training class.

:)
0
 
esu4236Author Commented:
Resolved myself.
0
All Courses

From novice to tech pro — start learning today.