Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Turn off IE Enhanced Security Configuration for All Users on Windows Server 2008 R2 RDS Server

Posted on 2013-02-04
5
Medium Priority
?
2,091 Views
Last Modified: 2013-02-09
Working with a RDS on Windows Server 2008 R2 (terminal services) server that I have turned off IE ESC using Server Manager. When I open all programs, even those that request Internet information, I do not receive any warnings. When standard users open programs that access the Internet, they are prompted with "Content within this application coming from the web site listed..." Sometimes the programs works and other times they just crash. Users have even attempted to add the sites stated into the Trusted Sites zone. I can't seem to find the right area to modify the setting so that users are no longer prompted with this warning.
0
Comment
Question by:GISCOOBY
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 5

Expert Comment

by:tjc123
ID: 38852178
0
 
LVL 2

Author Comment

by:GISCOOBY
ID: 38852279
tyc123: thank you, but that is how I had it originally configured with IE ESC turned off for all users and admins. Works for Admins, not users.
0
 
LVL 2

Accepted Solution

by:
GISCOOBY earned 0 total points
ID: 38852356
I ended up configuring it from GP using Computer Policy\Admin Templates\Windows Components\Internet Explorer\Internet Control Panel\Internet Zone, setting it to a lower security zone.
0
 
LVL 83

Expert Comment

by:David Johnson, CD, MVP
ID: 38853120
I ended up configuring it from GP using Computer Policy\Admin Templates\Windows Components\Internet Explorer\Internet Control Panel\Internet Zone, setting it to a lower security zone.

That is not really a fix and will work until you get security audited.

Open Control Panel, click Add or Remove Programs, and then click Add/Remove Windows Components.
Select Internet Explorer Enhanced Security Configuration, and then click Details.
Click to select the check box for the users or groups that you want to apply the enhanced security configuration to: For administrator groups, For all other groups, or both, and then click OK.

This is a better solution source: http://support.microsoft.com/kb/815141/en-us#63
    Click Next, and then click Finish.
    Restart Internet Explorer to apply the enhanced security settings.
0
 
LVL 2

Author Closing Comment

by:GISCOOBY
ID: 38870829
Found the solution myself. Expert comment was not applicable.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Ready to improve network connectivity? Watch this webinar to learn how SD-WANs and a one-click instant connect tool can boost provisions, deployment, and management of your cloud connection.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OfficeMate Freezes on login or does not load after login credentials are input.
For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question