• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 502
  • Last Modified:

Can't setup "OWA" access on a droid phone.

Hi Experts!

We have a really strange problem with a newly installed server (SBS 2011) and OWA access via droid smartphones.

Here's the deal.  I know this isn't a firewall issue, etc., because I can use OWA from anywhere using a web browser and log in as any user and it works fine.

When I try and setup the user accounts from a droid smartphone (I've tried SEVERAL different brands/models), I can't get the user accounts to setup.  Sometimes they'll setup, but not sync, other times they won't setup at all.  However, I can setup the admin account on those droid devices and they work just fine.

So, why will the admin account work fine, but the user accounts won't?

Thoughts?

Thanks!
0
tganus
Asked:
tganus
  • 3
1 Solution
 
xterminatorCommented:
I have seen this happen with user logon rights set.
The 'Logon To' feature of these users were set to a single computername inside the network. OWA wasn't working, set them to 'allow to logon to any computer' and OWA started working.
As the Admin account is working, it doesn't sound like an certificate issue.
0
 
tganusAuthor Commented:
I checked this setting on the user in question and he already showed "Log into all computers" under his accounts Properties.
I also tried disabling the requirement for a device password in Exchange Activesync setting but this had no effect.

It's frustrating, my iphone accepts his info, server address, everything, I get the cert error, and then get the checkmarks showing all the information was accepted and verified but then I get a "Cannot get mail - The Connection to the server failed" error when refreshing the inbox.
0
 
Craig BeckCommented:
Have you actually allowed those user accounts the right to use ActiveSync or OWA?
0
 
tganusAuthor Commented:
After some searching I found it was a silly checkbox on each user's security tab.

First you open AD USers and Computers, then click View and check the "Advanced Features" option. This let's you view other tabs for each objects properties, including a Security Tab for users.

Under this security tab you click the "Advanced" button to open a new dialog, at the bottom of which is a "Include Inheritable Security Settings." I checked this and suddenly all the group memberships and access rights were applied properly, letting Active Sync work. My test account didn't have any problems because as a new user this was already checked properly.
0
 
tganusAuthor Commented:
Researched the problem more fully and found it wasn't an exchange error at all, but an Active Directory permissions issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now