Solved

Drupal 7 ical time zone issues

Posted on 2013-02-04
6
492 Views
Last Modified: 2013-02-08
I am new to drupal and just setup a new website using drupal 7.  The problem i am having is with the ical feature.  I am using Calendar 7.x-3.4 and Date iCal 7.x-2.3.  The problem i have is that whenever anyone imports the ical from my site the times for events are off by 6 hours, IE and event that starts at 8AM in my sites calendar shows up at 2AM through the ical.  I am in CST which explains the -6 hours but i can't seem to figure out how to correct this.  I would be happy to provide any further information if needed.
0
Comment
Question by:joshparker
  • 3
  • 2
6 Comments
 
LVL 13

Expert Comment

by:Arrow_1
ID: 38853069
Your time zone setting is probably incorrect. Go to your regional settings under admin/config/regional/settings and be sure your time zone is set properly.
0
 

Author Comment

by:joshparker
ID: 38854977
My time zone is configured correctly as America/Chicago.
0
 
LVL 16

Accepted Solution

by:
HagayMandel earned 500 total points
ID: 38858315
Check the event's field, @ admin/structure/types/manage/CONTENT-TYPE-NAME/fields/FIELD-NAME/field-settings, you'll find a select option box named"Time zone handling".
The defaults value, is the server's (Site's time zone), try changing it to"User's time zone".
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 

Author Comment

by:joshparker
ID: 38864213
This setting is set to sites time zone, is there a way to change it without deleting all of the content?  When i go to change it the site states "There is data for this field in the database.  the field settings can no longer be changed."  All is not lost if I have to delete and recreate the content, it would just be easier if i didn' have to.
0
 
LVL 16

Expert Comment

by:HagayMandel
ID: 38865407
0
 

Author Comment

by:joshparker
ID: 38868643
Changing the setting seems to have solved my problem!  All looks great, thanks for your help
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is for those that are having major problems with users upload files such as pictures to their profile. The solution is simple and has to do with correcting the directory paths. With some experimenting and testing i got it fixed. Note…
RTL (right to left) web applications aiming for audiences speaking languages like Hebrew or Arabic, are generally more complicated than the same applications aiming for audiences speaking Latin based languages. The main difference lies of course …
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.
A company’s greatest vulnerability is their email. CEO fraud, ransomware and spear phishing attacks are the no1 threat to a company’s security. Cybercrime is responsible for the largest loss of money to companies today with losses projected to r…

939 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now