• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 459
  • Last Modified:

ASP.net errors causing loss of connectivity to application

Hi Everyone,

We currently have a hosted application setup where we have one app server, one web server, and one DB all running server 2003.  For about 10 days or so we have been intermittently unable to access the application and are forced to reboot the app and DB servers to mitigate, the issue then occurs again and we have to reboot, etc.  

We have checked countless things and the only thing we can find that is logging around the time of the application hangs that might be related is the following:

Event Type: Warning
Event Source: ASP.NET 2.0.50727.0
Event Category: Web Event
Event ID: 1309
Date:  2/1/2013
Time:  12:23:03 PM
User:  N/A
Computer: ********
Event code: 3005 Event message: An unhandled exception has occurred.
Event time: 2/1/2013 12:53:03 PM Event time (UTC): 2/1/2013 5:53:03 PM
Event ID: 340b2d6d0f434e3799bcc286c5475b61 Event sequence: 2 Event
occurrence: 1 Event detail code: 0  Application information:
Application domain: /ML*****************
Trust level: Full     Application Virtual Path: /*******     Application
Path: D:\***********     Machine name: *********
Process information:     Process ID: 5820     Process name: w3wp.exe
   Account name: *************  Exception information:
Exception type: IOException     Exception message: The specified
network name is no longer available.
  Request information:     Request URL:
http://**************************     Request path:
****************.aspx     User host address: *****************
  User:      Is authenticated: False     Authentication Type:
Thread account name:*************    Thread information:
  Thread ID: 1     Thread account name: ********************
Is impersonating: False     Stack trace:    at
System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

Any ideas what these errors might indicate and what we could do to triage if they are in fact related?

Your help is much appreciated!
  • 2
  • 2
4 Solutions
I think you need to give a little more information about your setup.  You mention you have three boxes, are these boxes lan'd ?

When you say you are 'unable' to access the application, are you trying to connect to the application from an asp.net website or ?
I would suggest checking the Application Pool at IIS
seems like errors are shutting down the Application pool
when this error occurs, try an IISReset rather than a full reboot. would the issue get resolved ?
try that and let me know what happens
blinkme323Author Commented:
Thanks for the suggestions.  We ended up replacing the NIC on our SAN and that rectified the issue.
blinkme323Author Commented:
Replaced NIC on SAN
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now