EXSI 5 and physical serial ports

Hi,

I have a windows XP computer running on an ESXi 5 Server.
We need to plug a serial device to our ESXi server physical port and connect the port to our Windows XP computer.

I already connected the serial cable and added the port to the XP computer, but I'm not able to transmit/receive over the serial connection (I attached a picture of the configuration

Could I have the steps I need to follow?

Thank you,
LVL 1
Kaptain1Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Andrew Hancock (VMware vExpert / EE MVE^2)Connect With a Mentor VMware and Virtualization ConsultantCommented:
have you enabled Serial Ports in the Virtual Machine BIOS and added serial port devices to the VM?

please upload screenshots, USB to Serial Port Adaptors, work much better than standard serial devices.

USB devices can then be added to the VM, see my EE Article

HOW TO: Add and Connect a USB Device to a Virtual Machine, hosted on VMware vSphere Hypervisor ESX 4.1 ESXi 4.1, ESXi 5.0
0
 
Kaptain1Author Commented:
I changed the BIOS settings for the serial ports from Auto to Enabled, but I'm still not able to setup a connection. the Device manager shows COM1 and COM2 by default on all my other virtual machines located on the same EXSi server.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
how have you configured the VM Serial Port settings?
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
coolsport00Commented:
I have a serial device connected to an HP Proliant DL385 G7, that 'passes through' to an XP VM as well. It's a 'security' device. It's a bit "quirky" sometimes to get it to work. Edit the VM settings, select the Serial Port 1 you added, choose 'physical serial port' as your connection and from the drop-down choose "/dev/char/serial/usart0" and make sure the Device Status (at the top) has both 'Connected' and 'Connect at Power On' selected. If you don't have the right "Connection" selected, I believe the 'Connected' option will uncheck itself as it can't "see" the device you connected to the Host. At least, that's the issue I experienced.

~coolsport00
0
 
Kaptain1Author Commented:
Please take a look at the images. The host server does have two serial ports
image1.png
image2.png
0
 
coolsport00Commented:
Ok, did the config work I suggested? If not, try to use the "usart1" device from the drop-down to see if it 'connects'.

~coolsport00
0
 
Kaptain1Author Commented:
I already try using usrt1 device, but it didn't work
0
 
Kaptain1Author Commented:
Thank you for all your help.

I had an extra USB-Serial cable, and I was able to set up the serial by following your steps.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.