Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Auto-forward email from Public Folder in Exchange 2010

Posted on 2013-02-04
9
Medium Priority
?
4,953 Views
Last Modified: 2013-02-10
I'm trying to setup a public folder in Exchange 2010 that will automatically forward any emails dropped (copied/moved) into it, to an external recipient.

In the past with Exchange 2003 I have used the "Folder Assistant", configuring it through Outlook from the client side.

I've tried to set it up the same way but it doesn't send any email. I've also tried an internal recipient and that isn't working either.

It must try at least once to send the email because it then disables the rule.

I've attached screenshots to show how I've got it configured and also the rule after it's disabled.

Also this is in an SBS 2011 environment.

Any suggestions?
Capture.JPG
Capture1.JPG
0
Comment
Question by:dbasplus
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 9

Expert Comment

by:djsharma
ID: 38853750
0
 
LVL 9

Accepted Solution

by:
EMJSR earned 2000 total points
ID: 38853764
You may also want to check the following:

Have a look in the Exchange Management Console, in the Hub Transport Server (Organisation Configuration). “Automatic Forward” may be disabled. If you enable that setting, it should allow you to auto-forward emails.
0
 
LVL 23

Expert Comment

by:Malli Boppe
ID: 38853829
The screen shots that are attached  is that from the outlook.
Can you set a transport rul on the exchange server and see if that works.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:dbasplus
ID: 38857129
Some good ideas here, thanks. I'll go through them one by one -

djsharma - This server is not an upgrade from 2003, instead it is a new clean install - so there should be no problems with left over containers/OU groups from the 2003 server, which is what I think your links are pointing to?
I have also changed the permissions for the 'Default' and 'Anonymous' users to be 'Owner', along with all other users that might be using the folder, but this didn't help either.

EMJSR - I found the "Automatic Forward" setting on Exchange and it was indeed disabled so I thought this was going to be it, but sadly no. I've attached a screenshot just to confirm I've done it correctly.

mboppe - Shouldn't the default transport rules be fine for this? I can create a new one but what settings should it have?
Allow-automatic-forward.JPG
Public-Folder-Properties.JPG
0
 
LVL 9

Expert Comment

by:EMJSR
ID: 38857149
Have you restarted the Exchange Information Store and related services after making the change to enable "Automatic Forward"? Just to make sure you're not looking for further issues if not required. A lot of changes require a restart of the services to fully grip.
0
 

Author Comment

by:dbasplus
ID: 38857189
Yes I restarted the entire server just to make sure everything was applied and services were restarted.
0
 

Assisted Solution

by:dbasplus
dbasplus earned 0 total points
ID: 38857261
Got it working, but now I feel silly as it was so simple - just had to "Mail Enable" the public folders in Exchange! Don't know how I could've missed that one.

I've reset the permissions back to the default levels, and have tested for sending to both external and internal recipients and it works fine.

It wouldn't have worked without EMJSR showing me the "Automatic Forward" option which I never knew existed so they will get the points on this one.

Thanks everyone for your help with this.
0
 
LVL 9

Expert Comment

by:EMJSR
ID: 38857266
You know that's always the way; it's always the most simple, unsuspecting thing. Believe me, every day anew! Very glad you got it working though!
0
 

Author Closing Comment

by:dbasplus
ID: 38872814
The final step to get this working I found myself (Mail-enable the public folders) but EMJSR also provided excellent advice which was also required (enable Automatic Forward).
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
Are you an Exchange administrator employed with an organization? And, have you encountered a corrupt Exchange database due to which you are not able to open its EDB file. This article will explain all the steps to repair corrupt Exchange database.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
Suggested Courses

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question