Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2542
  • Last Modified:

ESXi iSCSI Datastore becomes inactive

Hi,

I have just setup a ESXi 5 server with Dual NIC in team (one active, one inactive) and have configured software iSCSI adapter to connect to my Iomega PX4-300D NAS via iSCSI.
It all works fine, then all of a suddon it drops out and the datastore becomes inactive.

I have the NAS sitting in its own VLAN running Jumbo Frames (9000) and have enabled these on the vSwitch, the iSCSI VLAN Kernel and the Cisco 3560 switch.

I was wondering what could be causing my issue? It works fine for 24-72 hours then falls offline.

Your help would be appreciated!

Cheers,

Mark
0
mark_06
Asked:
mark_06
1 Solution
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
first check if the ESXi server can reach the iSCSI SAN, use ping and vmkping from the console to ping the SAN.

Check and update firmware on the SAN.

Jumbo Frames enabled everywhere, SAN, Network Switches and ESXi?

see my EE Articles for hints and tips

HOW TO: Add an iSCSI Software Adaptor and Create an iSCSI Multipath Network in VMware vSphere Hypervisor ESXi 5.0

HOW TO: Enable Jumbo Frames on a VMware vSphere Hypervisor (ESXi 5.0) host server using the VMware vSphere Client
0
 
mark_06Author Commented:
Thanks for that. I rebooted the ESXi server and when it came back online I noticed that the vlan for the iscsi wasn't getting an IP from the DHCP. I have assigned a static IP now. I will see if that fixes it and let you know.
In the mean time I will have a read of the articles!
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
if your VMKernel does not have an IP, it will not be able to reach the iSCSI SAN!
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Vaseem MohammedCommented:
did you check the idle time settings on iOmega?
0
 
mark_06Author Commented:
So far so good. I will keep monitoring it.

In terms of the Iomega idle, I cannot seem to find a setting for it.
0
 
matthewttmCommented:
Hi Mark,

You can try creating a secondary path using the inactive NIC. Setup another VM Kernel, configure the IP the same as the VLAN of the iSCSI and add in the 2nd nic.
0
 
mark_06Author Commented:
It seems to be working ok now. I think the issue must have been the VM kernel having its IP Address renewed. Since I have changed it to static IP all seems to be work.
I am happy to close as resolved now. If it happens again I will create another question.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now