CF 9 Site - turn off "Enable Robust Exception"

Hi,
I maintain a CF9 Site on Windows 2008. I am not the one who wrote the site though I am a programmer.
The site was recently hacked and I posted here on EE to get help in locking it down.
One thing I found online was to disable "Enable Robust Exception". I went into CF admin and unclicked the box, but when I submit the changes, the box automatically is checked again.
I thought possibly the two boxes below it also needed to be uncheck (Enable Ajax Log Window and Enable Request Debugging output), so I tried unchecking those as well. But they all come back checked when I submit changes.
Then I found a suggestion online to put this at the top of my Application.cfc file
<cfset this.enablerobustexception = false />
I tried that and restarted the CF Application service but I still can't uncheck the "Enable Robust Exception" checkbox.
Any ideas or suggestions as to what is stopping me from un-checking it?
Thanks,
Nacht
LVL 1
nachtmskAsked:
Who is Participating?
 
SidFishesCommented:
that's odd....

you could try to modify the config neo-debug.xml file directly

usually in C:\ColdFusion{v#}\cfusion\lib

<var name='robust_enabled'><boolean value='false'/></var>

save and restart service...
0
 
_agx_Commented:
EDIT: Gah... never mind!  That's what happens when you take a phone call in the middle of posting ;-)

---------------------------------------------------
Silly question, but did you rule out the basics like cached page or javascript error occurring on the admin screen?

You can always change it in the config files.  Make a backup of {cf_root}\lib\neo-debug.xml first. Open it with notepad and look for the entry:

           <var name='robust_enabled'><boolean value='true' /></var>  

Change the value to "false" and restart CF.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.