Solved

Dreaded Exchange ActiveSync returned an HTTP 500 response

Posted on 2013-02-05
24
1,436 Views
Last Modified: 2013-02-06
Clients SBS 2003 server was syncing with phones fine.
Client got new software that allows access via IIS. (May or may not have bearing)
Had ISP change forward port 80 to server for the IIS access. (ISP manages Cisco firewall for client)(May or may not have bearing)
There was an issue with one of the pages for the new software, client dealt with company directly to resolve that issue.
Client calls several days later to say no smartphones are receiving email.
I have gone through all the settings in IIS (REF:AlanHardisty)
I have removed all the VD's from IIS and recreated. (twice)
I have attempted to remove IIS and Form Based
I still receive the HTTP 500 response error on testexchangeconnectivity.com
Any help would be greatly appreciated!!!
0
Comment
Question by:HaulnSS
  • 15
  • 9
24 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38857424
Okay - what changed?  Is port 443 pointing to the Default website through the firewall?

The 500 errors are nasty and can be a pain to get rid of, but not impossible.

DNS issues can also cause the HTTP 500 errors and could take a while to resolve with Q&A.

Alan
0
 

Author Comment

by:HaulnSS
ID: 38859365
Just to add, I have run SBS best practices and Exchange.

Here is one thing I omitted, not thinking it would make a difference, but let me throw it out there.
Being a little click happy, I changed asp.net, under the Default Web Site to 2.0.  Realized my mistake and changed it back.

DNS Event Viewer shows no complaints, realize that doesn't mean it's perfect.  

The client doesn't believe this problem started with the setup of their software, they believe it happened earlier the same day.  I logically believe it has to be related to something I did, setting up their new software portal.
0
 

Author Comment

by:HaulnSS
ID: 38859376
FYI:  OWA is working fine.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38859496
I have seen Activesync work happily with ASP.NET 2.0, but the SBS BPA will complain and suggest it is set back to 1.1.

OWA usually works happily - even though Activesync doesn't!

Can you outline what you did when setting up the software portal please.

Thanks

Alan
0
 

Author Comment

by:HaulnSS
ID: 38859555
I will get the directions I went by again for the portal.

Don't know if this means anything, but testexchangeconnectivity keeps timing out for me this morning, so I went to my phone to trying setting up a mailbox.

Android: If I setup all the correct information, I get Server responded with error, check your username and password then try again.  If I purposely type something wrong (username or password) it comes back right away and says username or password incorrect.  So, at least it seems that it is actually talking with the server.
0
 

Author Comment

by:HaulnSS
ID: 38859567
Here are the instructions I followed.
2003-Wintac-web-portal-instructi.pdf
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38859677
Okay - did you follow these instructions exactly (especially step 3)?:

Follow the instructions below from the Server before installing the Wintac Web Portal.
1. Click Start, All Programs, Administration Tools, Manage Your Server.
2. Click Add a Role, then click Next.
3. Select Application Server (IIS, ASP.NET).  Click Next.
4. Select FrontPage Server Extensions and Enable Asp.net.   Click Next.
5. Follow the on screen instructions.  Click Next.
6. Insert Windows Server 2003 CD if prompted.
7. Restart server if prompted
0
 

Author Comment

by:HaulnSS
ID: 38859697
Well, not exactly since it is 2003.

But IIS and FrontPage Server Extensions were already active.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38859843
Okay - so you didn't really touch them then?
0
 

Author Comment

by:HaulnSS
ID: 38859887
Correct
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38859903
Right - if you browse internally to port 80 on your server via IE e.g. http://servername

What do you see?  The new website?
0
 

Author Comment

by:HaulnSS
ID: 38859929
The website declined to show this webpage
Most likely causes: This website requires you to log in


http://servername/alogin.aspx

Gives me login for admin for portal
0
New My Cloud Pro Series - organize everything!

With space to keep virtually everything, the My Cloud Pro Series offers your team the network storage to edit, save and share production files from anywhere with an internet connection. Compatible with both Mac and PC, you're able to protect your content regardless of OS.

 

Author Comment

by:HaulnSS
ID: 38859954
FYI:  http://servername/default.htm - no longer opens SBS page

http://localhost/default.htm still shows SBS page
0
 

Author Comment

by:HaulnSS
ID: 38859980
I remember while configure the portal for new software, I did get this error once.

Event ID: 1062
It is not possible to run two different versions of ASP.NET in the same IIS process. Please use the IIS Administration Tool to reconfigure your server to run the application in a separate process.
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 38859988
Okay - so port 80 is now being grabbed by the new website and that means that Activesync won't be able to send internal queries to the default website.

Can you stop the new website and then test Activesync again please.
0
 

Author Comment

by:HaulnSS
ID: 38860023
Holy poop, that fixed testexchangeconnectivity.com.....  I hate it when it is something simple I completely missed....

How do I have both running?

Testing phone right now.
0
 

Author Comment

by:HaulnSS
ID: 38860029
Phones work!!!!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38860060
Okay - so you may need to add a host header to the other website and then test to see if you can have both running, or force the new site onto port 81 or another number that makes you feel warm and cosy ;)

Alan
0
 

Author Comment

by:HaulnSS
ID: 38860074
Host Header?  Like in DNS?

I feel incredibly stoopid that I never disabled the new portal and tried it....ugh.....
0
 

Author Comment

by:HaulnSS
ID: 38860082
Nevermind on host header, found info on it.

Thank you!!!!!!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38860176
Don't beat yourself up - sometimes when you are deep in a pile of proverbial it can be hard to take a step back and see the wood from the trees.

You are welcome - does that help the two sit alongside each other happily?
0
 

Author Comment

by:HaulnSS
ID: 38860184
Yes, the header is working!

I would give you a million points, if I could!
0
 

Author Closing Comment

by:HaulnSS
ID: 38860198
Obviously very knowledgeable with IIS, Very much appreciated!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 38860220
"I would give you a million points, if I could!"

No need - i'm happy with the ones I got, but appreciate the thought.

Glad all is working happily and happy to be able to help.

Let's hope it stays working.

Best wishes

Alan
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction At 19:33 (UST) on Tuesday 21st September the long awaited email arrived with the subject title of “ANNOUNCING THE AVAILABILITY OF WINDOWS SBS 7 PREVIEW”.  It was time to drop whatever I was doing and dedicate as much bandwidth as possi…
I’m often asked about newer and larger USB drives connected to SBS2008 and 2011 failing Windows Server Backup vs the older USB drives not failing. As disk space continues to grow and drive technology change SBS2008 and some SBS2011 end up with the f…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now