Selective relay for MS Exchange 2003

Hi All,

I have a Exchange 2003 front/back end setup and I have a requirement that we allow external members of a distribution list to send to everyone in the dist. list, even other external members. That's relaying, so I'm trying to figure out a way to allow this to happen and not make both of my Exchange servers open relays.

My testing so far indicates that making the internal server an open relay doesn't work because the external server refuses to relay the external recipients. I don't want to make the external server an open relay because we'll get blacklisted.

Does anyone have ideas on how to solve this problem?
rdroppAsked:
Who is Participating?
 
FDiskWizardCommented:
I'm trying to make sure I'm understanding your requirements.

Anyone on the list needs to be able to email the distro list? right?

That isn't exactly relaying... That's a distro list sending to members of the list.

Just thought of something and looked at one of our internal lists to verify. I think under the Exchange General TAB you select: "Accept Messages...  ONLY FROM:  "
and add the Distro List so that members of the list can send to it.
0
 
hecgomrecCommented:
If these people are not "on the go" I can suggest you to authenticate or validate the relay for their IP addresses.

Another solution is to get them authenticated in your domain and select on your connector that only authenticated users can relay.

Good Luck
0
 
rdroppAuthor Commented:
Unfortunately, they are at large external instutitutions and universitites. I don't think I can reliably identify a single IP address or even a range for their email servers and authentication is also not feasible either.
0
 
rdroppAuthor Commented:
It's a good point and helped solve the problem. The issue was that the expansion server was left as the default "any server in the organization", and we had the accept messages field set to "from everyone" . The problem is that the front end server is both faster and locked down, so it did most of the expanding and rejects all mail from non-internal addresses. Setting the expansion server to the internal server fixed the problem, since it can access the dist list and see that it's not relaying (as you correctly point out).

I've also reset the accept messages field to  the distribution list only, so that it's less likely to become a mini spam vector.

Thanks!
0
 
rdroppAuthor Commented:
It was a thoughtful question and suggestion that led me to the solution, even though it didn't directly solve it. I really appreciate it.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.