Exchange 2003 on SBS 2003 - Stopping 3rd Party Spam Filtering - Restoring Inbound SMTP


An Exchange server (Exchange 2003 on SBS 2003) that I administer will be discontinuing 3rd Party Spam Filtering (Like GFI, Postini).

In my tests of changing the MX record, I have not been successful in getting inbound email to be restored, to come through. Last year, before using a 3rd party spam filter inbound mail worked swell.

MX was:
10     (1/2hour - for testing)

MX for testing:
10     (1/2hour - for testing)

So when I remove "" no mail flows through Exchange, all users are affected.
When "" is in place mail flows fine. resolves correctly to the static IP for the router and TCP Port 25 forwards from the router to Exchange 2003 on SBS 2003 IP o.k. Port 25 is open on the Windows firewall.

My thought is that there is something in Exchange impeding the inbound mail flow.
The only settings I am aware of affecting the 3rd party spam filtering are:
1. SMTP Connector, Access, Connection and Relay, allowing *

Any thoughts?

Who is Participating?
Alan HardistyConnect With a Mentor Co-OwnerCommented:
Check the setting on your Default SMTP Virtual Server> Access Tab> Connection Control Button - make sure that it is set to All Except The List Below.  When using a 3rd party Spam Filtering Service, only specific IP's will be configured to allow just the spam filtering providers mail servers to connect.

Alan HardistyCo-OwnerCommented:
My comment https:#a38857776 should have happily resolved the problem.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.