Solved

Setup Guest Wireless

Posted on 2013-02-05
17
345 Views
Last Modified: 2013-02-27
I have a AP Netgear  proSafe NDAP350 . I have setup a internal wireless and it is working fine. I need to setup guest wireless to only access to the internet. There is a PIX firewall in the network. Any idea to how setup guest wireless to access to the internet only ?
0
Comment
Question by:roozbehdec
  • 8
  • 7
  • 2
17 Comments
 
LVL 20

Expert Comment

by:agonza07
ID: 38858242
What kind of switch is the AP connected to?

Also, do you have an available port on the PIX?

What you need to do is configure a second SSID for your guest network and configure a trunk port between the AP and Switch. Allow your internal wireless to trunk over your native VLAN (#1) and configure the second SSID to use a different VLAN (let's say #2.)

Terminate VLAN #2 at an available port on the PIX, configure the port with a security level of about 25... considering your LAN is security level 100 and DMZ is 50... configure IP, DHCP, NAT and firewall rules and you should be good. Guest SSID will only go out the internet and not into your network.
0
 

Author Comment

by:roozbehdec
ID: 38859911
I will work on this project tomorrow. I don't know if the switch is smart or not? Can we do it if switch is not smart? Also what firewall rules do I need to configure on the PIX ?

Do I need to define DHCP on AP or PIX for Vlan 2 ?

As I know vlan 1 is untagged in AP now. I need to create a Vlan 2 and set as tagged  right ?

Access Point has only one port and it is connected to the wall jack port and it goes to the switch.  I am wondering if switch is not smart what we can do.

Please give me your idea?

Thank you
0
 
LVL 21

Expert Comment

by:Rick_O_Shay
ID: 38860781
Some Netgear AP's have that function available and you just need to turn it on in the config.
I don't know if the model you mentioned has that or not but will check.
0
 
LVL 21

Expert Comment

by:Rick_O_Shay
ID: 38860852
Sorry. I looked in the manual and don't see guest as a standard feature of that model.
0
 
LVL 20

Expert Comment

by:agonza07
ID: 38862055
Looks like a higher end AP, so Guest SSID will need to be manually configured.

You need a smart switch, at least one that will do trunking. Do you have an available port on the PIX, maybe it can do the trunking for you in some way...
0
 

Author Comment

by:roozbehdec
ID: 38862517
I don't know how can I configure PIX ? port e0/4 is availabe and I set ip address 172.16.1.1 for this port. I setup DHCP range 172.16.1.5-10. How can i route network 172.16.1.0 to internet ?
Inside network is 192.168.1.0
Outside interface has public IP address

I need to know how route network 172.16.1.0 to internet  ?

Please help me.
0
 
LVL 20

Expert Comment

by:agonza07
ID: 38862563
How about your switch. Did you get a model number off it, and did you find out if its managed and can do trunking?
0
 

Author Comment

by:roozbehdec
ID: 38862570
I have to check tomorrow but I suppose switch is smart. I need to know how can I route nwtwork 172.16.1.o to internet ?
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 20

Expert Comment

by:agonza07
ID: 38862573
What version of software you running on the PIX?
0
 

Author Comment

by:roozbehdec
ID: 38862583
PIX 506e  Ver 6.3(5)
0
 
LVL 20

Expert Comment

by:agonza07
ID: 38862588
Cool. Can you also send a sanitized config over?
0
 

Author Comment

by:roozbehdec
ID: 38862610
here is config:

login as: pix
Sent username "pix"
pix@192.168.168.1's password:
Type help or '?' for a list of available commands.
PetoPIX506>
PetoPIX506> enable
Password: ************
PetoPIX506# show run
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ar/LW09/uFRJW8X2 encrypted
passwd vV1zKa/K8VdgmYBS encrypted
hostname PetoPIX506
domain-name petocpas.com
clock timezone MST -7
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
no fixup protocol tftp 69
names
name 192.168.168.3 peto-sbs
name 192.168.168.0 local_lan
object-group network sasaddr
  network-object host 24.249.163.178
  network-object host 184.183.9.183
access-list 101 permit ip local_lan 255.255.255.0 10.10.20.0 255.255.255.0
access-list inbound permit icmp any any echo-reply
access-list inbound permit icmp any any time-exceeded
access-list inbound permit tcp object-group sasaddr any eq 3389
access-list inbound permit tcp any host x.x.x.x eq www
access-list inbound permit tcp any host x.x.x.x eq smtp
access-list inbound permit tcp any host x.x.x.x eq pop3
access-list inbound permit tcp any host x.x.x.x eq https
access-list inbound permit tcp any host x.x.x.x eq 993
access-list inbound permit tcp any host x.x.x.x eq 995
access-list inbound permit tcp any host x.x.x.x eq 3389
access-list 102 permit ip local_lan 255.255.255.0 10.10.20.0 255.255.255.0
access-list pixtosas permit ip local_lan 255.255.255.0 10.20.20.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.x 255.255.255.240
ip address inside 192.168.168.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool Remote-dhcp-pool 10.10.20.100-10.10.20.150
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list pixtosas
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3389 peto-sbs 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface pop3 peto-sbs pop3 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface smtp peto-sbs smtp netmask 255.255.255.255 0 0
static (inside,outside) tcp interface www peto-sbs www netmask 255.255.255.255 0 0
static (inside,outside) tcp interface https peto-sbs https netmask 255.255.255.255 0 0
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 1:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http local_lan 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community sy83-y562E
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set trmset1 esp-aes-256 esp-sha-hmac
crypto ipsec transform-set austinlab esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set trmset1
crypto map map1 10 ipsec-isakmp dynamic map2
crypto map map1 client authentication LOCAL
crypto map maptosas 67 ipsec-isakmp
crypto map maptosas 67 match address pixtosas
crypto map maptosas 67 set peer 184.183.9.183
crypto map maptosas 67 set transform-set austinlab
crypto map maptosas interface outside
isakmp enable outside
isakmp key ******** address 184.183.9.183 netmask 255.255.255.255
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 13 authentication pre-share
isakmp policy 13 encryption aes-256
isakmp policy 13 hash sha
isakmp policy 13 group 2
isakmp policy 13 lifetime 28800
isakmp policy 18 authentication rsa-sig
isakmp policy 18 encryption des
isakmp policy 18 hash sha
isakmp policy 18 group 1
isakmp policy 18 lifetime 86400
vpngroup peto0508vpn_09 idle-time 1800
vpngroup petovpn address-pool Remote-dhcp-pool
vpngroup petovpn dns-server peto-sbs
vpngroup petovpn default-domain peto.local
vpngroup petovpn split-tunnel 101
vpngroup petovpn idle-time 3600
vpngroup petovpn password ********
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 10
console timeout 20
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
Cryptochecksum:7085dd1660b9b6b686d50ab1a8944211
: end
PetoPIX506#
0
 

Author Comment

by:roozbehdec
ID: 38862658
Could you please write the commands I need to configure PIX firewall for guest SSID ?
0
 
LVL 20

Expert Comment

by:agonza07
ID: 38862807
I'm a little rusty on my PIX, but it'll be something like this:

interface ethernet4 auto
nameif ethernet4 Guest security50

access-list GuestACL permit icmp any any echo-reply
access-list GuestACL permit icmp any any time-exceeded
ip address Guest 172.16.1.1 255.255.255.0

nat (Guest) 1 0.0.0.0 0.0.0.0 0 0

access-group GuestACL in interface Guest

Open in new window

0
 

Author Comment

by:roozbehdec
ID: 38862823
Thank you, I will try and let you know.
0
 

Author Comment

by:roozbehdec
ID: 38865505
Switch is not smart and also PIX doesn't have available port. I am wondering if we need to purchase another wirless router just for guest and  then setup the fireawall to route the wirless router to the internet only. Is that possible ? What is your idea ?
0
 
LVL 20

Accepted Solution

by:
agonza07 earned 500 total points
ID: 38865551
Just get a Smart switch that supports VLANs and 802.1q trunking and you'll be set.

Here's a good read on how to configure the VLANs on the 506
http://www.dslreports.com/forum/remark,17005127
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

Need WiFi? Often, there are perfectly good networks that don't have WiFi capability - and there's a need to add it.  - Perhaps you have an Ethernet port into a network but no WiFi nearby. - Perhaps you have a powerline extender and no WiFi at the…
For Sennheiser, comfort, quality and security are high priority areas. This paper addresses the security of Bluetooth technology and the supplementary security that Sennheiser’s Contact Center and Office (CC&O) headsets provide.  
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now