Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Sharepoint 2010 listform.aspx sort order

Posted on 2013-02-06
5
Medium Priority
?
569 Views
Last Modified: 2013-02-07
How do I change the order in which my list columns are displayed in listform.aspx? A field that I want to appear at the top of the form is displaying at the bottom of the form (I want the "Labor Category" field in the attached graphic to appear after "Opening Number". I changed the field order in the relevant list view, but the order of the items in listview.aspx remains unchanged.
listform-aspx.jpg
0
Comment
Question by:dgmoore1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 50

Accepted Solution

by:
Ingeborg Hawighorst (Microsoft MVP / EE MVE) earned 2000 total points
ID: 38862312
Hello,

The list view and the order of the fields therein has no connection with the order of the fields in the form.

Here are the steps to change the order in the forms:

- open the list and on the List Tools ribbon click the List tab > List Settings
- click Column ordering below the list of fields
- in the ensuing screen select the order of the fields by changing the numbers in the drop-down.

cheers, teylyn
0
 

Author Comment

by:dgmoore1
ID: 38862362
That is what I did, but the order of the items in the form did not change. I set the ordinal number of the Labor Category column to 2, but the column remains sorted last.
0
 
LVL 50
ID: 38862870
Can you post the screenshot of the screen where the column order is changed?
0
 

Author Comment

by:dgmoore1
ID: 38863930
I just revisited you original message - I changed the column order in the view, not at the "Column Order" link. But my list settings page does not include the Column Ordering link for some reason - I have Create Column, Add from existing..., and Indexed Columns, but no Column Ordering. I checked with our admin team and they have no idea why that link is missing.
0
 

Author Closing Comment

by:dgmoore1
ID: 38863961
I found my problem. Column Ordering is disabled if Allow Management of Content Types is enabled. I turned off Management, fixed the column order, and turned Management back on. Thanks
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There is one common problem that all we SharePoint developers share: custom solution deployment. This topic can't be covered fully in this short article, so all I want to do in this one is to review it from a development-to-operations perspectiv…
We had a requirement to extract data from a SharePoint 2010 Customer List into a CSV file and then place the CSV file into a directory on the network so that the file could be consumed by an AS400 system. I will share in Part 1 how to Extract the Da…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question