Xenapp Java Client "User Name or Password is incorrect"

I have installed Xenapp Fundamentals.
Any user except Administrator receives "User Name or Password is incorrect" message from Server 2008R2, when trying to start published application with Java client (http://myserver/seamless1.html).

Even adding the user to Administrators group does not help. It allows Administrator only.
All works fine if running ICA file from desktop.
Help please!
Thank you
Who is Participating?
Ayman BakrConnect With a Mentor Senior ConsultantCommented:
What version of java client are you using?

Are you using web interface or storefront? If storefront check this CTX article:


If the above is not your case then please check the event viewer on your 2008 R2 XenApp server for any Windows Security Auditing events/failures and post them here. We will be able to assist you better the more information you provide.
msacc97Author Commented:
Hi, Mutawadi

I'm using Receiver for Java 10.1
This is web interface.
Attached is screenshot from Event Viewer.
All error messages are the following:

- System
  - Provider
   [ Name]  Service Control Manager
   [ Guid]  {555908d1-a6d7-4695-8e1e-26931d2012f4}
   [ EventSourceName]  Service Control Manager
  - EventID 7023
   [ Qualifiers]  49152
   Version 0
   Level 2
   Task 0
   Opcode 0
   Keywords 0x8080000000000000
  - TimeCreated
   [ SystemTime]  2013-02-06T16:46:20.576955100Z
   EventRecordID 339080
  - Execution
   [ ProcessID]  864
   [ ThreadID]  16784
   Channel System
   Computer WIN-RJ......
- EventData
  param1 Citrix WMI Service
  param2 %%5

Thank you
Ayman BakrSenior ConsultantCommented:
check this thread for the specific error ID 7023


For your java client specific issue try one of the following:
1. Install JRE 7 update 3
2. Check with java client and internet browser other than Internet Explorer
msacc97Author Commented:
I have version installed on both client and server
The thing is that applications opens fine in all types of browsers that I have (IE, Chrome, Firefox), but only if I login as Administrator.
And it says that credentials are wrong, if any other user.
I have a feeling, that the problem might be in permissions, not in the software itself.
Also, I noticed that the error 7023 happens every minute, and thus not directly related to login attempts..

I'm not that familiar with admin stuff, so not sure which errors and were should I look for..
Sorry for misleading if any..
Thank you for your help
msacc97Author Commented:
Problem resolved.

1. run gpedit.msc
2. go to computer configuration - windows settings - security settings - local policies - user right assignment
3. edit item "Allow log on through Terminal Services" and add the local group "Authenticated User"

Mutawadi, thanks for advising me to look into events log.
Event Viewer - Windows Logs - Security - showed failed logins
All the other credits go to:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.