Implementing Sharepoint 2010 RBS & Search

Posted on 2013-02-06
Last Modified: 2013-02-26

I am trying to resolve the 4gb limitation of MSQL Express. I upgraded to MSDE Express R@, supposed ot now be 10GB limited. MY Sharepoint Search is stopped as result of 4gb limit. I have recreated the application and verified correct DB size but still same error.

Yeserday I found this could be avoided using RBS. Installed the various componet of RBS. Tried the command line for RBS but cannot see my SQL server instance name, tried all variations of the name. If I run the RBS_amd64 GUI install it works for my WSS_Content but my search db's are other names and when i try install enable RBS on them it fails.

Some of the errors
The installer has encountered an unexpected error. The error code is 2769.
Remote Blob Storage on the database has failed with error message:
A network-related or instance-specific error

for DBInstance have tried "sharepoint", "servername\sharepoint" with quotes, without them etc.

any help appreciated.

Question by:escadmin
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3

Author Comment

ID: 38859801

Figured out the command line to get WSS_Content setup with RBS.
Had to enable named pipes and used servername\sharepoint.

Now I run the same command on for my other "search" databases, do not see any errors but the RBS tables never get created in databases.


Author Comment

ID: 38859923
Tried to enable the databse anyway.
$cdb = Get-SPContentDatabase <ContentDatabaseName>
$rbss = $cdb.RemoteBlobStorageSettings

This failed as my search db is not a content database. For tesing i just created a new Content databse in sharepoint. Added the blob folder filegroup etc.  
Followed this link again

Ran the comnad above again.
$cdb = Get-SPContentDatabase <ContentDatabaseName>
$rbss = $cdb.RemoteBlobStorageSettings

See the wss_content_test database but message "SQL remote blob storage must be installed on each contect database" i have run the command several times. compare output to original WSS_Content log files and you can see the tables are not being created on the 2nd databse.


Accepted Solution

escadmin earned 0 total points
ID: 38929903
No response, closing ticket.

Featured Post

Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
This article summaries thoughts and ideas from two years of sustained use. It provides good reasoning to make the jump to Windows 10.
Using examples as well as descriptions, and references to Books Online, show the documentation available for datatypes, explain the available data types and show how data can be passed into and out of variables.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question