Solved

dns has critical issue

Posted on 2013-02-06
17
366 Views
Last Modified: 2013-02-13
hi i have the following:

- master dc win 2003 /ad/dns/dhcp server
- file & print server
- xp desktops connected

i have not made any changes and my network was ok yesturday although i did shut the whole system down all night and all eventviewers did not show any signs of issues.

today i booted my master dc up and in the eventviewer is states:

!the dns server has encountered a critical error from the active directory.  check that the active directory is functioning properly.  the extended error debug info (which may be empty) ie "".  the event data contains the error!

step 1 - ive cleared cache/and old files etc and restarted the dhcp & ok and the dns ok!
step 2 - i accessed the dhcp log and it stated the following:

the log was temporarily paused due to low disk space etc etc
dns update request to the named dns server
dns update failed
dns update successful

step 3 - restarted master dc but same issue

step 4 - deleted temporary files etc & ran defrag on c:\
step 5 - rebooted system

i ran the following:

- dcdiag - all ok
- netdiag - all ok

still same issue above

note:  as im not running anything else on this master dc and have not done for quite sometime, i presume somwhere i may just need to remove some logs or something from somewhere.

i did not have this below added before but now i have:

locate hklm\system\currentcontrolset\services\ntds\parameters.
 add a new dword value named “repl perform initial synchronizations”, with a decimal value of 0. evidently, this keeps ad and dns from querying each other at the same time after startup.

qn1. can anyone assist ?
0
Comment
Question by:mikey250
  • 12
  • 3
  • 2
17 Comments
 
LVL 23

Assisted Solution

by:Suliman Abu Kharroub
Suliman Abu Kharroub earned 300 total points
ID: 38861376
Run: dcdiag /test:dns
0
 
LVL 8

Accepted Solution

by:
piyushranusri earned 200 total points
ID: 38862792
did you check on dns event log ( you check event viewer of what ?)

does it reply if you run nslookup
did you restart dns server and dns client services
did you run ipconfig /flsuhdns and registerdns

are user are able to connect network ?
and new device installed or upgraded has been done


please share the output
0
 

Author Comment

by:mikey250
ID: 38863504
hi sulimanw,

no i did not run : dcdiag /test:dns - will try
0
 

Author Comment

by:mikey250
ID: 38863515
hi piyushranusri,

(just to let you know or until i can replace my hdd for a larger hardrive i mounted an extra harddrive ie d:\storage that is actually shown in as the following c:\storage.  this is where i run my backup stuff and i still have over 5gb left, but it appears that my master dc does not make use of this mounted space!!! so i ran the 'compress' folders and subfolders for the time being which now shows over 2gb free!!!

(i will try those now)

i did the following:
run: eventvwr - same issue

- opened dns & viewed eventviewer there - same issue
- dns server - yes restarted services
- dns client - i did not restart
- ip config /flushdns - no i did not - as i thought clear cache & stale record would do same job
- ip config /registerdns - no i did not - as i thought clear cache & stale record' would do same job!!

currently i did not boot any other node to the network because if dns was not working i did not think any point as all that would happen is they would be using local account or temporary account, although yes im aware once dns/dhcp was up & running a user could log on and when they logged off, that new data would then be uploaded via the roaming profile.

step 1 - ive now done:

- ipconfig /flushdns - ok
- ipconfig /registerdns - ok
- netdiag - all tests passed
dcdiag - shows all other tests passing except below:
starting test: systemlog
an error event occured. eventid 0x00000010
time generated: 02/07/2013 11:42:32
event string could not be retrieved
.......................pdc-001 failed to test systemlog
0
 

Author Comment

by:mikey250
ID: 38863541
hi piyushranusri,

ive run all tests you suggest but same issue!!
0
 

Author Comment

by:mikey250
ID: 38863562
hi by: Sulimanw,

dcdiag /test:dns - responds "test not found. please re-enter a valid test name"

ive been looking at this link and none seem to work:

http://technet.microsoft.com/en-gb/library/cc731968(v=ws.10).aspx

note: admin.pak & sup tools are already installed.
0
 
LVL 23

Assisted Solution

by:Suliman Abu Kharroub
Suliman Abu Kharroub earned 300 total points
ID: 38863574
0
 

Author Comment

by:mikey250
ID: 38863725
yes the only server on is the master dc!

ive also installed the resource kit but not really understanding the commands and i keep getting the command syntax incorrect.
0
Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

 
LVL 23

Assisted Solution

by:Suliman Abu Kharroub
Suliman Abu Kharroub earned 300 total points
ID: 38863741
try dcdiag /dnsall
0
 

Author Comment

by:mikey250
ID: 38863774
hi sulimanw,  invalid syntax & i have used most of these commands in the passed and not sure why this is happening now.

the only 2 things that are showing an issue is:

- eventviewer on the master dc shows this 'dns' issue and all else is switched off
- & the dhcp log - hence yesturday clearing temporary interfiles and all the rest in various places and running defrag as explained above!!!

- i even changed my paging file the other day from 382 to 500 & changed the max from 768 i thinkg to 500 also.  so ive just changed them back to min 500 & 500 max and rebooted but exactly same issue.

- other than ad/dns/dhcp on same master dc im only running daily but to 'replace old and overwrite' a daily backup and ive checked and file is small but ive been doing this a couple of weeks but ive added nothing else to increase data!!

- i suppose i could re-install 'admin.pak & sup tools' again!!  -  ive now re-installed both

note: both my file & print server & desktop pc logon fine and even my xp desktop is not prompted with logging on with a 'local or temp account' which tells me this is ok and the specific issue is to do with my dns, although my dhcp states low disc space.  i have not installed anything new on the pc & i did add originally another 'cname' in the dns to test a simple webpage, but since this issue occurred i remove this 'cname'.  so other than the 'cname' ive done absolutely nothing else!!!!!!!!!!!!!
 
- i might have to do a restore on my back up!!
0
 

Author Comment

by:mikey250
ID: 38864047
hi sulimanw,

i have not run my backup yet but just to let you know as all logs on ok ie:
- file & printer server - uses static address anyway so no use of dhcp really
- xp desktop - yes uses dhcp and yes the original address is in place and logs onto network with no prompting of the 'local or temp' file which is good.
- xp desktop - ive checked the eventviewer system container and it shows: event id 3019 - "the redirector failed to determind the connection type" - which is acceptable although not sure why it does not prompt a local or temp profile when logging on.  oh well it must have what it needs as files are still being saved to and from when i logon and off and also tested this.

qns1. so unless you have anymore things i can try i will in the next 5 mins run the 'restore backup' ?
0
 

Author Comment

by:mikey250
ID: 38864117
hi sulimanw,

ive decided to remove the following from the domain:

step 1
- opened dns and delete all traces from domain
- closed and reopened dns
- restarted dns
- evenviewer still shows same issue

note: i was not sure if i should completely remove dns via master install features altogether so ive decided to do the below instead:

step 2
- xp desktop removing from domain
- file and printer server removing from domain

step 2
- i will remove dns features 'dc' altogether and reboot dc

step 3
i will re-add and configure dns & hope this resolves issue

note: im not even sure if i do need 'admin.pak and sup tools' on file & printer member server as all they do is assist with troubleshooting and as it is a member server most troubleshooting can be done from the 'dc' as this holds the 'dns/dhcp' server anyway.

it must be a harddrive low disc space issue even though i explained earlier exactly what my space was and that i had mounted it, but no expert has responded on that!!!!!!!!!!!!!!
0
 

Author Comment

by:mikey250
ID: 38864479
yes my steps worked all is back up and tested that no eventviewer issues in:

- master dc
- file and print member server
- xp desktop

thanks for the advice anyway!!
0
 

Author Comment

by:mikey250
ID: 38864565
hi sulimanw & piyushranusri

qns1. it would be nice to know why the following failed ?

- dcdiag - successful
- netdiag - successful
- ipconfig /flushdns - successfull
- ipconfig /registerdns - successfull
- dcdiag /test:dns - fail
- dcdiag /dnsall - fail
0
 
LVL 8

Assisted Solution

by:piyushranusri
piyushranusri earned 200 total points
ID: 38866922
please correct if i m wrong

 it seems that you have a domain named “com” under the DNS zone “domain.com” and under “com”, you have another domain named “domain”. This might be a misconfiguration. If so, I suggest that you remove the whole “com” folder under the DNS zone “domain.com". After that, the error should stop in dcdiag testing.


and for dcdiag/dns fail---seems you were using old support tools and after you had downloaded R2 version support tools


did you perform  ntdsutil and metadata cleanup

do you have another NIC which having 127 IP, please remove that At command prompt run ipconfig /flushdns, ipconfig /registerdns, and dcdiag /fix

and seems before that you had configured forwarder and revers look up zone and its picks some where 127 IP.


in your case there is multiple issue and mis-configuration.

will suggest you please take a deep test for your domain configuration and setting
0
 

Author Comment

by:mikey250
ID: 38867223
morning piyushranusri, this domain has not gone public as yet and no its (.local).

also im using windows 2003 standard and not got r2 and have been told in order to use r2 i would also need windows 2003 r2.

ive only ever used:

- ipconfig /all
- ipconfig /release
- ipconfig /registerdns
- ipconfig /flushdns
- netdiag
- dcdiag
- dcdiag /fix

never used:

- dcdiag /test:dns - fail
- dcdiag /dnsall - fail

yes ive used the below in the passed for another setup:

- ntdsutil and metadata cleanup

only got 1 dc and static settings are fine and primary dns on install was: 127.0.0.1 but changed prior to (dcpromo) to master dc main ip as dns running also on same dc.

ive just looked on the internet and can see there is a public domain name exactly the same as my private netbios part of my .local, which i did not know as did not think to check but thats ok as planning on changing anyway!
0
 

Author Closing Comment

by:mikey250
ID: 38883616
although the command told to use did not resolve my issue, in the end i resolved it myself!

the commands that im familiar with and what i did use were successful when showing a response to the command:

- ipconfig /all
- ipconfig /release
- ipconfig /registerdns
- ipconfig /flushdns
- netdiag
- dcdiag
- dcdiag /fix

never used: the below commands appeared to be incorrect syntax

- dcdiag /test:dns - fail
- dcdiag /dnsall - fail

although no comment has come back regarding myself not having a copy of win 2003 r2 as i have win 2003 standard, im not even sure if this is why the above commands and others on the 'url' provided also 'failed'.

that being said i have a pre-downloaded version of sp2 which ive had for upto 5 years that ive saved on my external hdd, so if there was an updated version of sp2, well im not sure and if this was the reason the above commands and various others did not work, well i do not know.

it would have been nice to know what was the issue surrounding those commands that did not work!!

all responses though were well appreciated either way!!!!!:)
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

I've written instructions for one router type, but this principle may be useful for others of the same brand and even other brands of router. Problem: I had an issue especially with mobile devices that refused to use DNS information supplied via…
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now