Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 854
  • Last Modified:

HAMACHI and Exchange on SBS 2008

Has anyone ever setup hamachi on a sbs 2008 server and used it for remote exchange /outlook use?

I am going to attempt it using this article and was hoping to find someone who can coach me through it.

http://help.logmein.com/SelfServiceRenderFAQAsPDF?Id=kA030000000DGBfCAO
0
ewassman
Asked:
ewassman
  • 10
  • 8
1 Solution
 
Rob WilliamsCommented:
You may have routing issues as Hamachi uses a 5.x.x.x subnet.  they can be resolved by adding static routes but why do you need Hamachi?

You can use rpc/http between Outlook and Exchange which is already set up, more secure, and much less problematic, or if you want to use a VPN, which I would discourage, SBS has a built-in VPN service.
0
 
ewassmanAuthor Commented:
I tried setting up http before, but I didn't have any luck, can you shoot me a link that would help with that? All I really want is for remote users to use outlook with my exchange server. I would prefer to do without VPN.
0
 
Rob WilliamsCommented:
On SBS 2008/2011 Exchange is automatically configured to support rpc/http when you run the "configure your Internet address" wizard.  

You also have to install a 3rd party SSL certificate, as per:
http://blog.lan-tech.ca/2012/05/17/sbs-2008-2011-adding-an-ssl-certificate/
or use the SBS self-signed certificate.  If you have any smartphones you will definitely want to buy a cert.

Configure the PC for Outlook Anywhere (RPC over HTTP) .
-Assuming the Exchange account is already set up on the PC, within Outlook open the Exchange e-mail account
-Select More Settings.
-On the Connection tab, under Exchange over the Internet, select Connect to my Exchange mailbox using HTTP, and then click Exchange Proxy Settings. The Exchange Proxy Settings dialog box appears.
-Under Use this URL to connect to my proxy server for Exchange, type the URL for the computer running Windows SBS 2008. Use the following format:  remote.domain.abc, where servername.com is the external name of the computer running Windows SBS 2008.
-Select Connect using SSL only, and then select Mutually authenticate the session when connecting with SSL.
-In the Principal name for proxy server dialog box, type a second URL for the name of the proxy server. Use the following format:
msstd:remote.domain.abc, where remote.domain.abc is the external name of the computer running Windows SBS 2008.
-Select On slow networks, connect using HTTP first, then connect using TCP/IP.
-Under Proxy authentication settings, select Basic Authentication.
-Click OK twice. Click Next, click Finish, And then click Close.

Open Outlook and type your Windows SBS 2008 user name (in the format DOMAIN\user name) and your password. You can now work with your Outlook mailbox.
(condensed from:  http://technet.microsoft.com/en-us/library/cc794265(v=ws.10).aspx )
0
Learn Veeam advantages over legacy backup

Every day, more and more legacy backup customers switch to Veeam. Technologies designed for the client-server era cannot restore any IT service running in the hybrid cloud within seconds. Learn top Veeam advantages over legacy backup and get Veeam for the price of your renewal

 
ewassmanAuthor Commented:
ok lets assume I have a computer that is not on the domain and has never been setup on the exchange server.
0
 
Rob WilliamsCommented:
Just create the account the same way that you would as if on the domain, only it will not be able to connect until you add the steps above.

The whole process is described in the link I provided:
http://technet.microsoft.com/en-us/library/cc794265(v=ws.10).aspx

Also if not using a purchased SSL certificate you will need to copy the SBS self-generated one from  \\Servername\public\Downloads\Install Certificate Package.zip  to the PC and install
0
 
ewassmanAuthor Commented:
I'm not having any luck it say it "cannot communicate with the exchange server" after several minutes of "loading profile" I'm using outlook 2010 would that make a difference? I do have a trusted cert installed.
0
 
Rob WilliamsCommented:
Perhaps try running the rpc/http Exchange Connectivity Test.  This will help to identify if it is a server, routing, certificate, or Outlook config.
https://www.testexchangeconnectivity.com/

Outlook 2010 is fine.  If you create the Outlook Exchange account while connected to the domain with 2010 it actually auto-configures, but I appreciate you are off-site.

Make sure for username in Outlook when prompted you use  domain\user
0
 
ewassmanAuthor Commented:
I am getting the user and pass challenge from the domain when I launch out Outlook and I am putting in the domain\username

here is what failed when I ran the test:

      Attempting to ping RPC endpoint 6001 (Exchange Information Store) on server myserver.mydomain.local.
       The attempt to ping the endpoint failed.
        Tell me more about this issue and how to resolve it

http://technet.microsoft.com/en-us/library/db543644-c252-47ee-a70b-4f60770083dc.aspx
0
 
ewassmanAuthor Commented:
probably my firewall I don't have those ports open on it.
0
 
Rob WilliamsCommented:
You only need port 443 for rpc/http, which needs to be forwarded from the router to the server.  Those other ports are only used internally.

Do you have any other security software on the server that might have a software firewall.
0
 
Rob WilliamsCommented:
Also....might you have disabled IPv6 on the server?
0
 
ewassmanAuthor Commented:
I don't believe ip6 is disabled...I see ip6 in the network properties. I'm not seeing anything blocked on the firewall, I am forwarding port 443 otherwise OWA wouldn't work from the web, which it does.
0
 
ewassmanAuthor Commented:
No other security software.
0
 
Rob WilliamsCommented:
Were there no additional details about the failure?  Usualy there is another line indicating the details of the failure between; "The attempt to ping the endpoint failed"  and  "Tell me more about this issue and how to resolve it"
0
 
ewassmanAuthor Commented:
0
 
ewassmanAuthor Commented:
sorry and this line was under the link

      Additional Details
       The RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime process.
I'm done for today will pick this back up tomorrow.

thanks for the help so far.
0
 
ewassmanAuthor Commented:
I'm going to start a new question for this issue, thanks for getting me this far.
0
 
Rob WilliamsCommented:
Thanks ewassman.  Sorry I was out of the office all day yesterday.
I see by your other question you were able to resolve.  Good to hear.  What was it that enabled you to connect, the instructions there look identical to above, only shorter.

--Rob
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 10
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now