Solved

joomla and placing tabs on 5 images on a page example {tab=data1} {/tab}

Posted on 2013-02-06
6
392 Views
Last Modified: 2013-04-02
have the below code that has lost the tab code to give each of the images its own tab
have looked around but cannot seem to get the
{tab=data1}
{tab=data2}

{/tab}

have tried this but just shows us as {tab=data1} but no tab any ideas plesae

<div id="tab" class="tab_block">
    <div class="tab_container">
        <div id="tab1" class="tab_content"><!--Content-->
            <div class="clear"><img class="img_indent" src="images/stories/tab_pic.jpg" border="0" /> <img src="images/stories/microsoft.gif" border="0" />
                <p>A Microsoft </p>
                <span class="inf">Receive</span> <a class="b_more2" href="index.php?option=com_content&amp;view=article&amp;id=105&amp;Itemid=98"></a></div>
        </div>
        <div id="tab2" class="tab_content"><!--Content-->
            <div class="clear"><img class="img_indent" src="images/stories/tab_pic2.jpg" border="0" /> <img src="images/stories/cisco-logo.gif" border="0" />
                <p>Systems</p>
                <span class="inf"> market.</span> <a class="b_more2" href="index.php?option=com_content&amp;view=article&amp;id=105&amp;Itemid=98"></a></div>
        </div>
        <div id="tab3" class="tab_content"><!--Content-->
            <div class="clear"><img class="img_indent" src="images/stories/tab_pic3.jpg" border="0" /> <br />
                <p>service</p>
                <span class="inf"> get</span> <a class="b_more2" href="index.php?option=com_content&amp;view=article&amp;id=105&amp;Itemid=98"></a></div>
        </div>
        <div id="tab4" class="tab_content"><!--Content-->
            <div class="clear"><img class="img_indent" src="images/stories/tab_pic4.jpg" border="0" /> <img src="images/stories/comptia-logo.gif" border="0" />
                <p>entry</p>
                <span class="inf">guaranteed</span> <a class="b_more2" href="index.php?option=com_content&amp;view=article&amp;id=105&amp;Itemid=98"></a></div>
        </div>
        <div id="tab5" class="tab_content"><!--Content-->
            <div class="clear"><img class="img_indent" src="images/stories/tab_pic5.jpg" border="0" /> <img src="images/stories/msoffice-logo.gif" border="0" />
                <p>users.</p>
                <a class="b_more2" href="index.php?option=com_content&amp;view=category&amp;id=36&amp;Itemid=90"></a></div>
        </div>
        <!-- tabs end --> <!-- tabs end --></div>
</div>
0
Comment
Question by:sydneyguy
  • 3
  • 2
6 Comments
 
LVL 53

Assisted Solution

by:COBOLdinosaur
COBOLdinosaur earned 200 total points
ID: 38864720
I have no idea what this is supposed to mean:

{tab=data1}
{tab=data2}

{/tab}


And a piece of out of context code tells me nothing about how the page is setup.  Without a link to the page I doubt there is not much we can offer as a solution.

Cd&
0
 
LVL 4

Expert Comment

by:webtechgal
ID: 38875022
As @coboldinosaur stated, it is kind of hard to help without a little more information about your setup, like -

Version of Joomla
Template name and from where (custom or i.e., rockettheme)
Site url

Just taking a stab in the dark, if this is an extension for creating tabbed input (like Tabber?), is the extension published/activated? Check your extensions manager to see if it is published.
0
 

Author Comment

by:sydneyguy
ID: 38875648
running 1.5
template is theme542  from        Smeliy
I am just fixing it i did not build it have not looked at the template it had a previous working tab on the page but some one else deleted an image as well as the control code that ran the page
it is mod_custom  tabs and they are all enabled and it has this code on the module page and is published in the user5 position
below is the code thats on the page now

<div id="tab" class="tab_block">
    <div class="tab_container">
        <div id="tab1" class="tab_content"><!--Content-->
            <div class="clear"><img class="img_indent" src="images/stories/tab_pic.jpg" border="0" /> <img src="images/stories/microsoft.gif" border="0" />
                <p>A Microsoft </p>
                <span class="inf">Receive</span> <a class="b_more2" href="index.php?option=com_content&amp;view=article&amp;id=105&amp;Itemid=98"></a></div>
        </div>
        <div id="tab2" class="tab_content"><!--Content-->
            <div class="clear"><img class="img_indent" src="images/stories/tab_pic2.jpg" border="0" /> <img src="images/stories/cisco-logo.gif" border="0" />
                <p>Systems</p>
                <span class="inf"> market.</span> <a class="b_more2" href="index.php?option=com_content&amp;view=article&amp;id=105&amp;Itemid=98"></a></div>
        </div>
        <div id="tab3" class="tab_content"><!--Content-->
            <div class="clear"><img class="img_indent" src="images/stories/tab_pic3.jpg" border="0" /> <br />
                <p>service</p>
                <span class="inf"> get</span> <a class="b_more2" href="index.php?option=com_content&amp;view=article&amp;id=105&amp;Itemid=98"></a></div>
        </div>
        <div id="tab4" class="tab_content"><!--Content-->
            <div class="clear"><img class="img_indent" src="images/stories/tab_pic4.jpg" border="0" /> <img src="images/stories/comptia-logo.gif" border="0" />
                <p>entry</p>
                <span class="inf">guaranteed</span> <a class="b_more2" href="index.php?option=com_content&amp;view=article&amp;id=105&amp;Itemid=98"></a></div>
        </div>
        <div id="tab5" class="tab_content"><!--Content-->
            <div class="clear"><img class="img_indent" src="images/stories/tab_pic5.jpg" border="0" /> <img src="images/stories/msoffice-logo.gif" border="0" />
                <p>users.</p>
                <a class="b_more2" href="index.php?option=com_content&amp;view=category&amp;id=36&amp;Itemid=90"></a></div>
        </div>
        <!-- tabs end --> <!-- tabs end --></div>
</div>

Xpert Tabs:  installed but couls still not get running


SP Tab set up but also could not get running

am going to run on another site to see if its the site or me

JCE Editor have this menu set up, i thought that it had a tabs button on the menu but not on this one
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 4

Accepted Solution

by:
webtechgal earned 300 total points
ID: 38891238
Ouch. Joomla 1.5.x is an old version at this point. Anything you install new would probably not work with that version.

This syntax that you presented...
{tab=data1}
{tab=data2}
{/tab}

was previously used by NoNumber Extensions (nonumber.nl) for their Tabber extension. The syntax is a little different in the newer Tabs extension.  

I think what you have is attempts to use several different kinds of tab inclusions.

You might try this if the Tabs plugin is installed -
{tab1=Microsoft}
Microsoft
{tab2=Systems}
Systems
{tab3=Service}
Service
{tab4=Entry}
Entry
{tab5=Users}
Users
{/tabs}

If that builds the tabs on a page, then you can add the images and links you need.

My other suggestion might be to look for a previous backup that had the missing page code you need.
0
 

Author Comment

by:sydneyguy
ID: 38893031
no... no back up i just got dumped with it, old it is but do not wish at this point to do an up grade will look at this and see what goes on. there are still a fair few plugins for 1.5 so will also re-vist them
0
 

Author Closing Comment

by:sydneyguy
ID: 39042664
thanks for the help still looking at the issues as it is not yet resolved but thanks for the help
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Set email body to html using vbscript 6 22
WordPress website error - Unable to access website. 5 29
How to loop through records  using SELET COUNT 2 13
Session timeout 5 13
Nothing in an HTTP request can be trusted, including HTTP headers and form data.  A form token is a tool that can be used to guard against request forgeries (CSRF).  This article shows an improved approach to form tokens, making it more difficult to…
Find out what you should include to make the best professional email signature for your organization.
In this tutorial viewers will learn how to style elements, such a divs, with a "drop shadow" effect using the CSS box-shadow property Start with a normal styled element, such as a div.: In the element's style, type the box shadow property: "box-shad…
HTML5 has deprecated a few of the older ways of showing media as well as offering up a new way to create games and animations. Audio, video, and canvas are just a few of the adjustments made between XHTML and HTML5. As we learned in our last micr…

919 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now