Wrong SSL certificate being found

Hey guys,

When I auto-configure Mail in OS X to use my hosted Exchange account, it shows a certificate error and when I click more details, it shows a completely different company and website in the details.

When I try setup this account on iPhone and Android it fails, so perhaps it's being caused by the wonky certificate?

This is out of my area of expertise, perhaps someone can spot the problem and explain it to me too.

I have attached some screenshots.

Cheers.
Screen-Shot-2013-02-07-at-3.47.4.png
Screen-Shot-2013-02-07-at-3.51.2.png
Screen-Shot-2013-02-07-at-3.51.5.png
chippedAsked:
Who is Participating?
 
GiladnConnect With a Mentor Commented:
HI,

this is strange,  you are not mistaken, when you browse to:
https://www.proteum.com/owa
and click on the certificate -
it shows the same certificate with the wrong address, your exchange admins used a wrong certificate to host exchange in IIS and thisis the result, you can ignore and trust this certificate but I would advise to contact support and let them know about this error.

hope this helps,

G
0
 
GiladnCommented:
p.S

it also looks like OWA directory in IIS is redirecting to another page which make exchange autodiscover not work anymore, so in addition to my first response it looks like the account may not work even if you trust this certificate.

In order to fix this they will need to issue a new certificate for proteum.com and replace it with the existing one. so the name of the site (proteum.com) will match the name signed on the certificate.
0
 
chippedAuthor Commented:
Thanks you very much, I have forwarded your response to our guy who's setup the site.

I will award points once it fixed.

Cheers.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.